AML-S905X-CC (Le Potato) 480x320 ILI9486 3.5" SPI Touchscreen Display

Read the OP and follow those instructions.

wheres the op? idek how to use that code

Read the post at the top and follow the instructions.

How would I get a 320x240 2.8" TFT resistive touch screen working on Le Potato?

It’s got an STMPE610 resistive touch screen controller and uses IL19341 2.8" screen. I have this one one specifically.

Continuing from the last post since I (new user) can’t post more than two links per post :frowning:

I tried moving the 2J1 jumper as described above and installing driver with the instructions from Adafruit easy install. It didn’t work and I ended up with just an illuminated white screen on boot. I suspect that it’s because the GPIO layout on Le Potato is different than the Raspberry Pi?

I also tried just using the ldto commands listed in the instructions above but that obviously didn’t work because the touch controller and screen are totally different. I need to research what those commands are doing.

I’m using the 2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img Raspbian image which has kernel 6.0.12.

Any hints as to what I should try next would be much appreciated, love my Le Potato so far.

There is already an overlay for this display. You need to copy the overlay and add the touch screen node and driver compatible and any interrupt pins.

Hello, i got my display working but it is only showing the boot log and not the raspbian desktop. The touch work perfectly. So how could i make the desktop display on the spi display rather than on the HDMI?

Hello, I did all the steps on the ubuntu image and all worked fine no problem, but when I try on the raspbian image, specificly the “2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img.xz” image, when I do the steps the screen changes from white to black but it does not do anything else, only keeps black, and so far I have not found any way to select the display manually using the GUI.

This is a known issue with the default X11 config and we are working on it. Hopefully have it fixed by the end of the week.


Now I’m using the ubuntu base image and I cannot get it working as well, I’m using sway compositor.

Weston works out of the box. Not sure why Sway would not work for you.

1 Like

I tried weston as well and I have the same issue, was weston tested on the base image or the desktop image?

True, in my case it does not work on any of the images…

Weston is available on the server image. Just login and run weston.

1 Like

I downloaded the server image “ubuntu-22.04.1-preinstalled-server-arm64+aml-s905x-cc.img” and did the following:

sudo apt update
sudo apt upgrade
sudo ldto enable spicc-cs1
sudo ldto enable spicc-cs1-mpi3501

and still did not work, the screen is just white. it worked with the desktop image so I don’t know what am I doing wrong.

Read the OP in full. After enabling the screen permanently, reboot and then run weston.

it worked now :D, I never actually tried enabling the screen permanently, maybe if I had it would have worked on the other distros, thanks.

Another issue I have identified is that when using the Touchscreen, the CPU usage increases up to 30% and things are very slow, the screen lags and freezes sometimes, I remember it happening on the ubuntu desktop image as well.

SPI displays are not fast. Your software needs damage tracking for optimal performance. If you want good display performance, use HDMI instead.

Any updates? When can we expect it to be fixed?