Debian 12 Bookworm and 11 Bullseye for Libre Computer Boards

But without ssh enabled, how I can install/use this board headless ? Do I need to hook up a serial-usb cable ? I think, because this is a singleboard and setting up a serial-usb connection or a keyboard / hdmi is often not ideal, having an active sshd on boot might be a reason good enough :slight_smile:

No, this violates the default security state of the images. We will release server images with cloud-init to pre-configure the system with ssh settings but the base images will not have ssh.

Having the possibility to configure the image is a great solution ! thank you :slight_smile:

I really did not expect to see Debian images being released. Thanks guys.

And for those wondering about how well gnome runs, it’s just fine.

Tested the latest Debian Bookworm image on a Sweet Potato and it’s working great, nonetheless I have recommendations for a future release:

  • No keymaps are installed by default so dpkg-reconfigure keyboard-configuration has not effect and the local keyboard is stuck in US qwerty. You should include the kbd and console-setup packages by default to fix that.
  • I understand why the SSH server is not installed by default, but then why does the image include exim and openvswitch enabled by default? These are very specific applications that should not be part of a default installation.
  • systemd is configured to automatically create a swap file on the root filesystem which is probably not a good idea, especially if it’s a btrfs partition compressed with zstd. swap should be disabled by default or at least located on a dedicated swap partition.
1 Like

We will fix that on the next regen.

exim was carried in by some other package. openvswitch was included due to plans for Debian server release. We will drop it from the base image.

We do not create swap partitions where possible. Btrfs supports in FS swapfile with nocow so it is entirely reasonable to do so as it can be configured by the user. Swap partitioning is harder on the user and more prone to issues since fstab and other elements have to be created. There is no atomic way of doing this on first boot so that is less reliable when SBCs can crash at any time due to flaky power.

1 Like

We are planning to move to ignition pre-configuration for the images.

for LaFrite board (s805x-ac) which distro of DEBIAN 12 :

thank you

La Frite has onboard firmware so +arm64.img.xz. make sure to get the latest firmware update.

The default gnome desktop is quite heavy for the old Le Potato. It would be nice to have something lighter like xfce4. So I tried to boot into the base image and then install xfce4 through apt get. However it does not work. Need some help.

You can try the Raspbian 12 images we are releasing this week. They’re lighter since they use wlroots and don’t have the full Gnome stack. We won’t be releasing anything based on X11.

I recently purchased a Renegade ROC-RK3328-CC 4GB. I tried using Armbian at first but it seems it lacks out of the box accelerated graphics support unless you a legacy image and a community support set of packages. From there I installed debian-12-gnome-arm64+roc-rk3328-cc.img.xz and while it does seem to have accelerated graphics (checked via chrome about:gpu) the UI seems very laggy. I am booting from a microSD card (SanDisk 64GB Extreme microSDXC). Is this to be expected or am I am missing a step or two? Thanks.

You are running a full desktop OS on a 5W device. It is the same performance as a Raspberry Pi 3. Chrome is a very resource intense application especially with websites and their monsterous JS frontends. If you want to run desktop browsers, we recommend buying $80+ boards.

Sorry for not being clearer, I used chrome to verify the accelerated graphic support. My comment about the UI was around window manager being slow. Just trying to bring up the start menu seemed sluggish. I am comparing to a Pi 3A running Pi Raspberry OS. I am not trying to throw shade at the board, I am trying to make sure I haven’t done something wrong.

Try Raspbian 12 instead of Debian. Debian is geared towards full blown desktop with Gnome. Raspbian 12 is much lighter and thus faster on these low end devices.

Having trouble booting the image on a AML-S905D3-CC-V1.0C. I am monitoring boot via 3-pin serial port. I first booted an SD card with the aml-s905d3-cc-spiflash image. Result was:

Firmware updated
device 0 offset 0x0, size 0xfed70
SF: 1043824 bytes @ 0x0 Read: OK
Firmware read
Firmware checksum match
Flash Completed

I then wrote the debian-12-base-arm64+arm64.img image to the SD card and attempted to boot it again. With the SPI/MMC switch at SPI I get the following result:


This continues to loop. Powering off the board and moving the switch to EMMC results in the following after U-Boot loads :

U-Boot 2024.01+ (Jan 24 2024 - 00:11:25 -0500) Libre Computer AML-S905D3-CC

Model: Libre Computer AML-S905D3-CC Solitude
SoC:   Amlogic Meson SM1 (S905D3) Revision 2b:c (4:2)
DRAM:  2 GiB (effective 3.8 GiB)
Core:  406 devices, 33 uclasses, devicetree: separate
WDT:   Not starting watchdog@f0d0
MMC:   mmc@ffe05000: 1, mmc@ffe07000: 0
Loading Environment from FAT... Card did not respond to voltage select! : -110
** Bad device specification mmc 0 **
Card did not respond to voltage select! : -110
** Bad device specification mmc 0 **
Couldn't find partition mmc 0
Card did not respond to voltage select! : -110
** Bad device specification mmc 0 **
Couldn't find partition mmc 0
Error: could not access storage.
Net:   eth0: ethernet@ff3f0000
starting USB...
Bus usb@ff500000: Register 3000140 NbrPorts 3
Starting the controller
scanning bus usb@ff500000 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot:  0 
Scanning for bootflows in all bootdevs
Seq  Method       State   Uclass    Part  Name                      Filename
---  -----------  ------  --------  ----  ------------------------  ----------------
Scanning global bootmeth 'efi_mgr':
Card did not respond to voltage select! : -110
Failed to load EFI variables
Error: writing contents
** Unable to write file ubootefi.var **
Failed to persist EFI variables
Scanning bootdev 'mmc@ffe07000.bootdev':
Card did not respond to voltage select! : -110
Scanning bootdev 'mmc@ffe05000.bootdev':
** Can't read partition table on 1:0 **
** Can't read partition table on 1:0 **

The last line repeats for some time before the printing the following:

Unknown uclass 'nvme' in label
Unknown uclass 'scsi' in label
ethernet@ff3f0000 Waiting for PHY auto negotiation to complete......... TIMEOUT !
Could not initialize PHY ethernet@ff3f0000
ethernet@ff3f0000 Waiting for PHY auto negotiation to complete......... TIMEOUT !
Could not initialize PHY ethernet@ff3f0000
No more bootdevs
---  -----------  ------  --------  ----  ------------------------  ----------------
(0 bootflows, 0 valid)

Note: I have tried with multiple SD Cards (including one purchased with the device from LoverPi). Even the one used to successfully update the UEFI-BIOS results in same. Mounting the SD Card on another device shows the following result from fdisk -l /dev/sdb:

evice     Boot  Start     End Sectors  Size Id Type
/dev/sdb1  *      2048  524287  522240  255M ef EFI (FAT-12/16/32)
/dev/sdb2       524288 4718591 4194304    2G 83 Linux

I can also mount the partitions. So the issue does not appear to be the SD Card.

Do I have a defective device? Please advise next steps.

Adding additional data point to above. I also have an AML-A311D-CC_V1.0C that boots just fine into Debian Bookworm with Linux Kernel 6.1.61 from the SD card provided by LoverPi that fails as above with the AML-S905D3-CC-V1.0C! I believe this is another indication that the board is defective.

So in able to use the Solitude board that I’m having the issue with I used the Alta board to write an image to a eMMC and then used that eMMC on the Solitude. So now I have a working Solitude, so I now suspect that there is a hardware issue with the microSD on the Solitude!

Will there be any significant differences between using the images you provided here compared to following the steps in this video

for Debian 12 manual installation?
Is one option more stable?

Solitude is pickier about the MicroSD card. Whenever you have a boot issue, can you let us know the brand and model of the card you are using?