Get colored blank screen after booting Raspbian 11 on AML905X-cc board

While booting I get the usual splash screens with the Libre logo and display of files being loaded into the system. But when loading seems to be done all I get is a uniform colored screed. I’m new to Linux and these types of boards so I might be ignoring something obvious to most of you.

Troubleshooting General Boot Issues - Boot - Libre Computer Hub

Troubleshooting Boot Issues on Libre Computer AML-S905X-CC

Did you look at both of these ? I assume you did extract the compressed Image ??

You should just boot up to a standard Raspbian desktop with the Sunset Wallpaper !

Hi Lain:
I’ve since fixed part of the problem by replacing my power supply with a better one. However, I a different problem now. With Raspbian I can see it booting up but after about 10 seconds of a waterfall of file names the screen goes dark with the blue LED flashing while the Red and Green LEDs are lit. I don’t have this problem with Armbian. I would have liked to use Armbian however I intend to use this board with an Astroberry image for telescope control. I seem to run into this issue either using Win32Disk flash program or the Raspberry loader.

“After about 3 seconds, the bootloader should turn on HDMI and displaying the loading sequence. Certain types of displays with odd resolutions are not supported at this stage and it might not display anything during this step and the next steps. If the Green LED turns green and nothing shows on your screen, please post your screen brand, model, and EDID here.”

Have you a different monitor you could try ?

Just out of interest - After the Le Potato has booted up for a minute or so - Have you tried Ctrl Alt F1 ?

Are you sure that the Astroberry image will work on the Le Potato ?

Hi Iain:
I tried the CTL-ALT-F1 but it had no effect, either when after the screen went dark or before. The Green LED is lit so the board should be booting properly. After the screen goes dark the Red and Green LEDs are continuously lit while the Blue LED Flashes two times every second or so.
Other other people have had other non-RPi boards working with Astroberry. Using Armbian I’ve been able to get the IKOS suite to work but have not been able other programs like PHD guiding or other similar programs to work. I’m not skilled enough to recompile the various other programs to work with the Potato board. I do know people have made Astroberry work with other boards.
Right now I’d like to be able to get the Rasberry Pi suite on this board.

It was a bit of a longshot on the CTR-ALT-F1 and Understood about wanting to get Raspbian working.

We know the board works via your Armbian tests.

We know the Armbian SD card works.

We know the image works correctly, if you follow the instructions, due to all the other people who have installed it successfully.

Indications seem to be that its not a Power issue due to the LED’s & Armbian tests.

I would give it another shot using a fresh image on one of the recommended SD cards ???

Hi Ian:
Update on my Booting issues with Ubuntu and Raspbian.

So far I have not had any luck in getting either Ubuntu or Raspbian to display anything after booting up.
Could it be the memory cards? Ans:I went out and bought a pair of Sandisk Extreme SD cards and all seem to have the same issue with either operating system. I’ve loaded Astroberry using the same memory cards and loading programs and things come up right with my RBPi3. I then rewatched all the utube videos and have done the same steps in the same order numerous time with the same failed bootups. With Armbian there are no issues what so ever. It just comes right up without any issues.
Could it be my monitor? Ans: I took my potato board over to my brother in law to use a different monitor and still got a blank screen at the end of booting.
Could it be the version of the Raspbian? Ans: Finally today I decided to load up with Rasbian 10 instead of Raspbian 11 with the same result.

I’ve also tried to convert an RBPi operating system to Libre using the sudo apt updates with Git per other web pages. I got the first command to work but when I tried to load the actual Git update it asked for a user name and password. I could not find on Libre web pages where the required user names and passwords are located for either the normal download or for the Git way of conversion on a real RBPi. On the Boot troubleshooting pages they state that the user names and passwords are there so we should use them. I would if I could find them.

I get the feeling that I’m missing an important step(s) that intuitively obvious to knowledgeable Linux users that might not be spelled out on the web pages.

Is there something wrong with my board? Ans: It seems unlikely given the fact that Armbian works.

Thanks for taking the time to respond.


What screen are you using? Make and model?

Video of what happens?

Just to be 100% sure - you did extract the .xz file to be a straight .img file ???

My monitor is an LG 32GN50T-B monitor. The production code is 32GN50T-BB.AUSUMKM. I’m including an image of the boot up sequence where the text ends and the screen goes blank. Afterwards the Blue led flashes at about a 1Hz rate.

Hi Ian:
It appears that way as the loader only sees files with the proper extension. Also, I go through exact same sequence with Armbian too. I use WindDiskImager 1.0 and raspberryPi-imager_1.7.4.exe in my attempts.


Try updating the kernel to the latest version on a different monitor and plug it back into this monitor.