HDMI/Jack sound not detected using Batocera - AML-S905X-CC

I’m having issues with sound not going through the HDMI (have tried different cables and monitors/TVs) in Batocera (also tried Lakka with the same issue). However, I do get sound through my PS4 controller’s jack output.

When using dmesg I get the following:

hdmi-audio-codec hdmi-audio-codec.3.auto: Not able to map channels to speakers (-22)
hdmi-audio-codec hdmi-audio-codec.3.auto: ASoC: error at snd_soc_dai_hw_params on i2s-hifi: -22
gx-sound-card sound: ASoC: PRE_PMU: be.dai-link-2-playback event failed: -22

When using aplay -l I get the following

**** List of PLAYBACK Hardware Devices ****
card 0: Controller [Wireless Controller], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: LIBRETECHCC [LIBRETECH-CC], device 0: fe.dai-link-0 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

If I unplug the PS4 controller alsamixer doesn’t work saying: cannot open mixer: No such file or directory


The 9th field AIU ACODEC i2S Lane Select should be 0.

Also make sure your input voltage is below 5.5V. AML-S905X-CC No Analog Audio Issue

1 Like

Setting the 9th field to 0 seems to do the trick. I get audio from both HDMI and jack output.
Thank you!

1 Like