How to activate UART on ALL-H3-CC

I have the ALL-H3-CC board. I need to enable UART (serial port). Using raspi-config I enable Serial Port, reboot. But no serial port appears in /dev/.

Also tried this solution but no luck: Enabling and using UART
As with this user, when issuing ldto list command, there are no serial ports in the list.

Any pointers appreciated.

UART debug console is enabled by default on ALL-H3-CC. See Libre Computer Board Serial UART Connection and Setup Guide

GPIO maps can be found here for additional UART pins: GPIO Pin Header Maps and Wiring Tool for Libre Computer Boards

Which pins do you UART on?

I am trying to communicate with a RPi hat using UART (serial port) at 9600 baud. The pins are 8 (RX) and 10 (TX) on the 40-pin header. On the RPi, this port is referred to as /dev/ttyAMA0. This device does not exist on the Libre.

Also, I need to communicate with this same hat over SPI using pins 19 (MOSI), 20 (MISO), 23 (CLK), 24 (CS). On RPi, this port is referenced as /dev/spidev0.0, whereas this does not exist on the Libre.

Thank you

Bumping this question as the UART debug console is not what I am after. I need to enable UART (Serial) on GPIO pins 8 and 9 the same as the RPi, which is usually accessible as /dev/ttyAMA0. The app uses these pins to communicate with an attached hat.

Issuing ldto list there is no UART device available to enable. Here is the output of ldto list:

#Overlays available

System has been updated via sudo apt update and then sudo apt upgrade then reboot.

I was able to enable /dev/spidev0.0 by issuing the following
ldto enable spi0-spidev spi0 spi0-cs1
Not sure if spi0-cs1 is necessary or not. Is this the Chip Select pin?

Thank you for any assistance.

I am following up on this topic because it appears that I need to create a device overlay for the UART pins in order to enable them. Currently the ALL-H3-CC-* models don’t provide a pre-built UART overlay (see this) but the AML-905x has a pre-built overlay for UART (see here). Since the internal mapping is different, I can’t duplicate the AML dts file and compile it (tried this, no new entries appear in /dev, and when doing ldto disable it crashes the kernel (null pointer).

If anyone could help in writing the dtc file for the ALL-H3 chip to support UART1 (pins 8 and 10) that would be immensely helpful!

uart1 and uart1-rts-cts has been added to the wiring tool.