Le Potato Boot Failure (Reboot Loop)

I’m trying to get Ubuntu server running on my aml-s905x-cc board for the first time as it is brand new.

I’ve followed the general guide as well as the potato-specific guide.

Here are the specifics of my setup:
Power Supply: 2.5a @ 5V (Canakit Power Supply)
Memory Card: SanDisk 64GB Extreme microSDXC
Network: Ethernet cable connected
USB Keyboard
17" monitor connected via HDMI

Image: ubuntu-22.04.1-preinstalled-base-arm64+aml-s905x-cc.img.xz

Flashing tool: Balena - Flashing and verification are successful

What happened?

  1. The boot process succeeded the first time. I was able to log in via user/pass however I didn’t realize updates were performed in the background so I attempted to perform them manually. When that didn’t work, I rebooted the machine, and it fell into this reboot loop which I have attempted many different ways to resolve, unsuccessfully.
  2. I’ve tried reflashing the SD card with Ubuntu (Etcher) and Raspbian (Etcher and rpi imager) a few times. I’ve disconnected/reconnected the power supply. It all ends the same way.

Hopefully I’m able to post the image of the terminal output after I create my post.

Here’s the terminal output just before the reboot occurs:

After trying 10+ times last night, several times with a different SD card, I pulled the card out of the potato, and went to bed. I woke up, discovered the reboot button, pressed it, inserted the SD card, inserted power cable, and it booted into Ubuntu no problem.

I ran ‘sudo apt upgrade’ and when it finished ran ‘sudo reboot’.

I am now back in the reboot loop I initially described. No combination of removing/inserting the SD card / power cable and pushing the reboot button is helping. Any ideas are welcome.

What do you have connected on USB? Does this happen when no USB devices are connected?

Just a keyboard connected via USB. I removed it and it boots correctly now. I’m curious why this would cause this issue if you have a moment to explain.

Bad news is that when I connect the keyboard post boot (upper left port), the system doesn’t pick it up and I can’t type my login.

Tried another USB port (lower left) and it does get picked up. I’ve been able to apply updates, reboot (unplugging keyboard), and log back in so things are looking up.

Is this more than likely a physical issue with one of the USB buses or something else?

What is the make and model of the keyboard? It could be a power issue.

I’m having the same issue where the potato continuously reboots. I even tried removing keyboard/hdmi and I can see that it is still rebooting (green LED goes off about 30 seconds after going on cyclically).

I was flashing with Win32 DiskImager with Ubuntu Base 22.04.1 and 22.10 and with Raspberry Pi Imager with bullseye and buster.

Das Keyboards
Model: DASK4MKPROSIL-3G7-r1.2

I’m getting the same thing, same s905x-cc, with an apple keyboard.

This is something you can try with the latest images to avoid that issue: How to Disable USB Scanning at Boot on Libre Computer Boards

1 Like