Le Potato Wont Boot

Hello, I bought a Le Potato (aml-s905x-cc). I ordered it off of amazon and I am using a micro SD card, class 10, A1. With a 2.5Amp Power supply. After flashing the SD card with etcher or Raspbian 11 imager and I put the SD card in the potato nothing happens. I have done this with almost every OS the give you and have also looked at the distro server and all of that. I have tried the lite and desktop version but every time I just get a solid blue and red light. I have tried different power supplies and nothing changed. I did format the SD card before I flashed it and I also tried not formatting the SD card first but It made no difference. I am out of Ideas. Anyone else have a idea of what to try?

See Troubleshooting General Boot Issues

What kind of SD card? Don’t stray from the recommended cards, you will have a bad time.

I used a SanDisk Ultra and Extreme

We created a separate section called Boot. You can read through the threads of all the people with boot issues. We also pointed you to the link. It’s a power supply or MicroSD card or flash issue.