Libre Computer AML-S905X-CC eMMC Flashing Steps from Linux with pyamlboot

This helped me as well. :slight_smile: Thank you so much!

Is it the intention to use the eMMC module as a replacement for the SD card?

See Difference between MicroSD cards and eMMC Modules

Maybe I didn’t clarify myself good enough, sorry for that. My real question is: can I flash, for instance, the Raspbian image on the eMMC board so that the Le Potato SBC can boot from the eMMC module instead of the SD card? Which would mean that I can fully get rid of an SD card to boot up the system?

You can flash Le Potato’s eMMC. You can use the above guide to flash the regular SD card image to the eMMC and it will work. The other way is to just flash to /dev/mmcblk0 when booted from MicroSD card. Either way works.

Hi…I followed the procedure above and was able to successfully erase the emmc partition but I cannot get the next step to proceed. I have fully disconnected the La Frite board and powered it on exactly as before but every time I try to run the ums-emmc command it gives me the device not found error. I even tried re-running the erase-emmc as before but it also gives the same device not found error.

Is there a step I am missing? I only received the board and emmc modules a couple of days ago

interestingly enough, I didn’t hold down the reset button when I plugged in the LF board to my Pi and I then was able to run it. Not sure what difference that ended up making by not holding down that reboot button but it was enough that it worked.

1 Like

If there is no software on any boot device and the USB A next to the IR sensor is plugged into a USB host device, the board will go into USB load mode automatically.

I just got a ALL-H3-cc and an emmc module 32GB when i tried above command and substitute the name with all-h3-cc and tell script not found if try with the aml-s905x-cc it of course says device not found. can you tell me what command i should useing to erase-emmc and ums-emmc on a ALL-H3-cc board>


i just recently recieved by 128GB emmc module for my ROC_RK3328-CC now too. I would appreicate so help with flashing the emmc module. why is there not a pyaml boot for the this board?

pyamlboot is only for AML-* boards. For other boards, see the generic MicroSD card eMMC flashing instructions at the top of the post.

Should the emmc just get detected as /dev/mmcblk0 once i connected and power up the ROC_RK3328-CC in ubuntu? i see the MicroSD card in Gnome Disk utulity but not the Emmc

so still no luck getting with the EMMC on ROC-RK3328-CC, I was hoping for some help. Can’t seem to find any thing that tells you how to actually mount the emmc or how to tell it is actually connected properly. I have seen the generic MicroSD car emmc flashing instuctions

Method 2: Flashing via Linux

  • Network Connection or USB flash drive with image
  1. Flash a MicroSD card with Raspbian or Ubuntu.
  2. Download or copy the image to your OS.
  3. Extract the image.
  4. Use dd or Gnome Disk Utility to flash the eMMC. The eMMC should show up as /dev/mmcblk0. For dd, sudo dd if=IMAGE of=/dev/mmcblk0 bs=1M. Replace IMAGE with the name of the extracted file. You can also dd the compressed image directly via xz -cd IMAGE.xz | sudo dd of=/dev/mmcblk0 bs=1M. Replace IMAGE.xz with the path to the compressed image.

I try this but when i list disk i do not see the mmcblk0 listed. If I try step 4 it says the disk is full.
I was very excited to get my eccm modules but that excitement is starting to go away.
some help would be appreciated.


You either have the wrong eMMC or damaged eMMC.

I’ve been using Lubuntu installed over the Ubuntu Server image with pretty good results. It does most of what I want, even if it’s not as slick as Mate, which can be installed thew same way. I found both Mate and my beloved Xubuntu to be a little too heavy for Le Potato. I might try Mate out as my daily driver now that I’ve tried it on this board. I miss the old gnome.

Here’s what I done:
I flashed ubuntu server to eMMC with Etcher, booted up and did the new password mumbo-jumbo.
I then connected via Ethernet, and ran:

$ sudo apt update && sudo apt -y upgrade
$ sudo apt install lubuntu-desktop
$ shutdown -h now

The command for Mate is:
$ sudo apt install ubuntu-mate-desktop

The Command for Xubuntu is:
$ sudo apt install xubuntu-desktop

Has anyone successfully flashed a USB-Attached SATA drive using MacOS Ventura (UNIX) for Le Potato?

Decompress and use dd on the terminal, just be careful to specify the correct file/drive, there are no training-wheels with dd.

sudo dd if="/PATH/TO/IMAGE.img" of="/PATH/TO/DRIVE" bs=1M

I haven’t used anything past snow leopard, but back then there was a disk utility you could flash drives with too, may still be there if you want a GUI.

Etcher also works on Mac.

I tried this method because my system was finding the mmcblk0 device. It copied an image of the 2023-05-03-raspbian-bullseye-arm64-lite+aml-s805x-ac.img.xz to my AML-S805X-AC, but after booting I get a “No Partition table - mmc 0” then “device 0: unknown device”

Any ideas about how to fix the partitioning on the eMMC?