Libre Computer Cottonwood Alta TensorFlow Lite MobileNetV1 Guide

Tomeu said there are still optimizations available since the proprietary driver is around 20% faster. That would put it around 20ms.

The hardware decoders are a money pit. We tried at it multiple times but need some coordination with a lot of parties.

Ok, so as of right now, there is no decoder support? Is there anything in the pipeline?

Is it possible to use the gpu for any video acceleration?

There is decoder support for H.264/H.265/VP9 but numerous bugs. You can try through V4L2-M2M but it will require some work. We spent years on this and our consultancies never got it to work completely. GPU can do some color transforms through shaders.

Dear Librecomputer. I tried this Alta couple month ago. I purchased couple other vendors machines and reached certain success with it, but theis Alta does not do any good on me.
As it said in “instructional guide” I compile Libretech wiring tool and then:

sudo ./ldto enable npu.

After this commend I received message that overlay is applied and memory leak could occur is ovelay removed, but the console at that point get locked.
I tried it in Gnome, in Gnome over SSH, then in headless (All Debian 12), the outcome is still the same, after overlay applied the thing, any help will be appreciated. does not talk to me.
Please

You are on an old kernel version if it locks up while you are using the base/headless image. If you are using Gnome, it will crash.

Dear librecomputer, thank you very much for response. How I update the kernel? Last I used raspbian 12 downloaded from your repo, before that I used debian 12 same result, perhaps the ubuntu which I tried as well, crashed, you are right. Should I build the kernel/system myself or you can offer the system with kernel that works?
I am really fascinated to work on this, to try using both GPU and NPU and see what performance I can reach for object recognition.

sudo apt update
sudo apt dist-upgrade
1 Like

Wow, that easy? Thank you Librecomputer, I will try.

1 Like

Hi Librecomputer.

I have done all updates you have suggested.
The Kernel version on Debian 12 (headless) now is 6.1.92-15907-gf36fd2695db3
Still, after entering ‘sudo ./ldto enable npu’ the terminal just freezes no further input possible.

Are you using base/headless OS?

yes, I use Deian-12-base-arm64+arm64.img. Also, I tried Rasbian-bookworm-arm64-lite-all-h3-cc-h5.img

Also I tried access over SSH, from host Linux computer, same story, I believe SSH connection is not disappearing, just the terminal becomes unresponsive