Libre Computer Raspbian Portability Feedback

That all looks right. Can you run cat /etc/fstab just to make sure the image is not different than standard Raspbian images?

It should show the following on boot on the AML-S905X-CC unless there’s a very bad microSD card:

EFI boot manager: Cannot load any image
Found EFI removable media binary efi/boot/bootaa64.efi
xxxxxxx bytes read in 0 ms
Booting /ef i\boot bootaa64.efi

Pardon me for taking pictures with my phone. I got tired of scp files over lol. Thanks for your help on this
Here is the etc/fstab

Here is what the AML-S905X-CC is returning

This image is made from NOOBS. It’s not really a Raspbian image but a NOOBS image. The Raspbian portability script does not work on NOOBS since NOOBS has been dropped by the Raspberry Pi foundation.

Oh! well that’s great. I believe this came from the pi imager. Where should I source the original image ?

If you just need Raspbian, just use these images: Index of /ci/raspbian/11/

You can find the release notes by using the search function.

The moOde audio music player is built on Raspberry Pi OS for “the Raspberry Pi family of single board computers.” Running on an RPi4B, I used LRP to adapt the (64-bit) moOde image for use on a Le Potato board.

The result works fine on both RPi and Le Potato boards—within the expected limitations of the different platforms and their different configuration mechanisms, which don’t concern me at the moment.

Two questions:

  1. the kernel image for the stock Raspberry Pi OS on which moOde is built is configured for CIFS support. Looking at the kernel configuration file
# CONFIG_CIFS_DEBUG2 is not set

while the kernel image loaded by the LRP for the Le Potato board is not.

# CONFIG_CIFS is not set

Is it possible that future S905X kernels will built with CIFS support or am I going to have to roll my own?

  1. Raspberry Pi boards are hard to find at the moment. Has anyone ported the LRP to Linux running on something else—say a full-up Ubuntu/Debian/whatever x86 host?


CONFIG_CIFS should be enabled on our kernels. What is the output of uname -r?

Huh. I just downloaded and flashed latest moOde player image (rev8.2.1) to a uSB card, booted it on an RPi3B and then downloaded and executed LRP Booted the result on my le Potato. This time I got a kernel with CIFS support and all is good.

pi@moode:~ $ uname -a
Linux moode 5.19.16-04046-g062726298e8a #1 SMP PREEMPT Sat Oct 15 07:43:35 UTC 2022 aarch64 GNU/Linux
# gunzip /proc/config.gz to home directory and...
pi@moode:~ $ grep CIFS config
# CONFIG_CIFS_DEBUG2 is not set

Dunno know what happened previously but thanks for nudging :slight_smile:

Someone else brought up the CIFS issue a few weeks ago and it was fixed. All you really needed was to run sudo apt update and sudo apt dist-upgrade to get the CIFS kernel on your previous image. You don’t need to re-image and re-run the whole thing.

All I really needed was more coffee :rofl:

1 Like

I’m having an issue running for an aml-s905x-cc. It fails on line 251 when it’s trying grab the packages from apt. I see linux InRelease is one of the package sources, but I’m getting unable to locate package errors for linux-image-lc-stable-arm64 and linux-headers-lc-stable-arm64.

I’m running this on a RPi 3B+ Buster image.

Please post the full log. If you just need a Raspbian Buster, you can go to our download page and grab a pre-made image.

I was able to get it to work by changing line 251 to point at “testing” instead of “stable”. I noticed the repository had both of the packages above, but not with “stable” in the name.

Trying to patch AllStarLink beta 2.0.0 (Raspbian Buster 10)
After patching, it boots, but asterisk complains with “Unable to open ‘/dev/dahdi/pseudo’: No such file or directory”
Is this patch recompiling the kernel? If so, could it be possible to add the required /dev/dahdi?

You probably either need to make the module or use DKMS to make the module.

As for /dev/dahdi/pseudo, have you tried manually modprobing the module?

Check the output of dmesg as you modprobe the module.

dahdi is not even showing up in /dev

Another fail was pi-star. Tried their latest version image (buster also) but I get an out of space error…

dpkg: error processing archive /tmp/apt-dpkg-install-KS3elR/11-linux-image-6.0.8-00789-g99a6460d70b3_6.0.8-00789-g99a6460d70b3-1_arm64.deb (–unpack):
cannot copy extracted data for ‘./boot/vmlinuz-6.0.8-00789-g99a6460d70b3’ to ‘/boot/vmlinuz-6.0.8-00789-g99a6460d70b3.dpkg-new’: failed to write (No space left on device)
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

It is a 66.1MB partition. Maybe creating a 1GB partition would help, but when it booted, it expanded and utilized the entire 32GB, so I would have to shrink the partition first before I create a 1GB partition, move the content over and change fstab entry.

dahdi will not show up in /dev until the module is loaded. Have to confirm that the module supports Linux 6.x, compiles properly, and loads properly via lsmod.

Do you have a link to the pi-star images?

Index of /ASL_Images_Beta/Raspberry_Pi2_3_4 (
The /dev/dahdi issue is for AllStarLink, which loads, but it doesn’t stay running due to the dahdi…

Pi-Star Downloads -
The Pi-Star is another program. And it didn’t work. I booted with GParted and moved the ext4 (not resized yet) partition to give 64MB more to /boot and gave it 128MB before booting with PI and it all worked fine. Did the L-C-R-P patch but it did not boot. The hat doesn’t even work, so no sense in trying… I’m about to give up on these Libre Computers…

If I could at LEAST get AllStarLink working, I would be happy. I can replace my existing PI for AllStarLink with this Libre Computer and use Pi-Star with my existing PI. If I take the sdcard which doesn’t work and boot from PI it works.

On another note… There are Raspbian 9 releases which dahdi does compile (subdir seems to be the problem) as stated in this post:

www .linux .org/threads/unable-to-install-dahdi-dkms.39219/#post-152342

There is also another release but it’s in Arch Linux. Will that flavor be supported? Looks like I chose the wrong SBC…or hopefully someone will get this working?