Raspbian 12 Bookworm and 11 Bullseye for Libre Computer Boards

im having an issue with the sudo apt update command. all it says is

Hit:1 Index of /repo/ linux InRelease
0% [Connecting to archive.raspberrypi.org]Bus error

what am i doing wrong ?

What does dmesg say? Bus errors are usually because your SD card is dying or dead.

-bash: /usr/bin/dmesg: Input/output error
is what i get when i try dmesg

i tried dmesg |grep -i machine and it gave me the same message

Yeah, it’s definitely your MicroSD card dying on you.

welp it was basically new so that sucks. ok ill try a new one thanks

See Troubleshooting MicroSD Card Performance and Recommended MicroSD Cards

ill do that now thanks

so i rebooted it and ran dmesg again and found this
mmc0: error -22 whilst initialising SDIO card
and i ran$ sudo dmesg | grep mmc and got this
[ 3.315421] meson-gx-mmc d0074000.mmc: Looking up vmmc-supply from device tree
[ 3.315644] meson-gx-mmc d0074000.mmc: Looking up vqmmc-supply from device tree
[ 3.315835] meson-gx-mmc d0074000.mmc: allocated mmc-pwrseq
[ 3.356784] meson-gx-mmc d0074000.mmc: no support for card’s volts
[ 3.357343] mmc0: error -22 whilst initialising SDIO card
[ 3.966537] meson-gx-mmc d0072000.mmc: Looking up vmmc-supply from device tree
[ 3.966688] meson-gx-mmc d0072000.mmc: Looking up vqmmc-supply from device tree
[ 3.966871] meson-gx-mmc d0072000.mmc: Got CD GPIO
[ 4.124586] mmc1: new ultra high speed SDR104 SDHC card at address aaaa
[ 4.126355] mmcblk1: mmc1:aaaa SK32G 29.7 GiB
[ 4.132176] mmcblk1: p1 p2
[ 4.491919] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 4.913729] BTRFS: device label rootfs devid 1 transid 306 /dev/mmcblk1p2 scanned by btrfs (243 )
[ 5.023741] BTRFS info (device mmcblk1p2): using crc32c (crc32c-generic) checksum algorithm
[ 5.026495] BTRFS info (device mmcblk1p2): disk space caching is enabled
[ 5.043390] BTRFS info (device mmcblk1p2): enabling ssd optimizations
[ 5.044296] BTRFS info (device mmcblk1p2): start tree-log replay
[ 7.692033] BTRFS info (device mmcblk1p2: state M): use zstd compression, level 3

mmc0 is the eMMC which you do not have attached. Our images are pretty robust against data corruption but that does not mean there is no corruption or that the issue won’t happen again. There’s something not fully working with your MicroSD card so don’t leave any critical data without backup once you get such an error.

its a brand new install of the image i just started it trying to get octoprint up and going but i couldnt even get passed the apt update or upgrade. so there shouldnt be anything to important on it yet

This is why a verify cycle during flashing is needed. Probably data errors were already occurring during the write stage. See our MicroSD card posts.

Hey i have been wondering what is trb skipping?

It depends on the device you have attached. USB is a complex protocol and device implementations. TRB skipping issues are device specific.

Hi. I have a renegade and am having problems with ssh on it. I have a pi4 set up running for years and know how to set it up. I can see the renegade from my router but when I try to ssh into it the password is always incorrect. I ‘think’ that I’m supposed to put a file userconfig.txt in /boot/efi partition with a password using openssl. Is the command ‘openssl passwd -6’ and then answer when it asks for the password taking the output and putting it in the userconfig.txt file? I’ve tried that and tried the Raspberry Pi Imager. Same result. Oh btw trying to use the:
image. Any thoughts?

It is userconf.txt, not userconfig.txt. Please read the original post carefully.

Ok, silly me. That was it.
Thank you,

Will an image be released for aml-s805x-ac (la frite)?

AML-S805X-AC La Frite can use the standard +arm64 image. Make sure to flash the latest firmware first.

Hello, is there any news for Raspbian 12 Bookworm image for AML-S905X-CC since it was released recently?

We have internal beta already and will release it next week. It is not as good as Gnome + Mutter though.

1 Like