READ FIRST! Booting Resources

Troubleshooting General Boot Issues

Supplementary Boot Guide for AML-S905X-CC

I just bought the aml-s905x-cc. I tried to flash two different Sandisk SD cards but the result is the same - on the monitor, I see the “L” logo splash screen and some console messages, the las few lines are:

scanning bus usb@c9000000 for devices... WARN halted endpoint , queuing URB anyway.
Unexpected XHCI event TRB, skipping... (a bunch of 64 bit hex numbers)
"Synchronous Abort" handlerm esr 0x96000210, far 0xc
(a table of CPU registers)

I used “Raspberry Pi Imager” on MacOS in spite of the recommendation to use “Disk Utility”, because I’m pretty sure it’s impossible to write *.img files to disk with Disk Utility. The image I tried to flash is

I also tried flashing with “dd” per:

but result was the exact same as when I flashed with “Raspberry Pi Imager” - maybe I got a bad board?

I also just tried 2023-05-03-raspbian-bullseye-arm64+aml-s905x-cc.img and same result.

I solved the problem. Since the error seemed to involve USB, I unplugged the keyboard and the system booted! I plugged it back in after it booted and the keyboard worked.

Seems like a code change to the kernel would be needed to avoid the issue:

1 Like

The issue is usually USB keyboards with quirks that don’t respond in a normal compliant fashion. Which keyboard is it?

1 Like

It’s an Apple full-size keyboard with number pad.