ROC-RK3328-CC No boot problem

I am hitting my wits end, and I am about to return my board. I have tried using the Raspberry Imager on both Mac and PC. I have tried Balena Etcher on both PC and Mac. I have tried disk utility on Mac. I have done all of these with both the armbian and ubuntu image isos. I have tried three different cards; a 32gb Samsung Evo, a 128gb Samsung Pro Plus, and an 8gb Sandisk Ultra in every permutation of card-image-method to no avail. I’ve tried using three separate USB to microSD and inserting the micro into it’s full-size carrier adapter.

I am getting no video just solid red and green lights. I’ve tried two different 3A power supplies and I have checked the power and video with a Pi3B+.

Is there anything else I should try? Thanks.

In my earlier post I mentioned f3,

It does a credible job of diagnosing SD card problems. It’s a real hair puller to get Le Potato to boot the first time.

If you correctly flash the correct software, all of our boards will boot correctly. If you are having problems with multiple boards, there is something wrong with either your process or the machine you are using to flash or the MicroSD card.

Thanks, but it is just one board (from Amazon). 3 different SD cards, 3 different computers, 3 different methods of burning, 2 different power supplies, 2 different images.

Im having the exact same issue…I do get a green heartbeat though. Mine is from Amazon too.

where are you getting the images from? are you using libre distro isos?

Yes. I’ve tried both the Armbian and The Ubuntu.

I gave up. I was finally able to see it on my network. It was never fully booting or at least I never got an image on a monitor and could not ssh into it. I sent it back to Amazon. That was way more difficult than it needed to be.

I gave up as well. I wrote “This board is bad” on the inside flap of the box in case they resell it.

Smart move…maybe save someone some butt pain. As for me, no more of their boards.

If you get a heartbeat, then it could be that your display has a resolution that is not supported. What monitor are you using?

I tried 3 different monitors. None of them were 4K. They were either 1080 or 720. The card was the issue.

Did you wait 30 seconds?

Did you decompress the image?

Windows by default hides the file extension that indicates compression.