Troubleshooting General Boot Issues

We recommend grabbing a distribution from our website: Index of /ci/
These images are CI’ed so they are known to boot.

Armbian does not to my knowledge have CI integrated image tests. The builds could work or not work depending on the state of the Armbian codebase. It also uses ext4 which is less reliable on SBCs and prone to data errors.

MicroSD cards are generally compatible. It’s rare to have a compatibility problem. That said, we do have ones we recommend per the guides found all over this website.

Make sure you extract the image before flashing. Make sure you have the right image for your board and not the wrong board image.

Thank you. I will try the CI’d builds and double check everything.
I did indeed extract everything correctly and check that it’s the S905X.

Also, my system did not even appear to cross the boot stage (red and blue solid lights). Even if the OS had a problem wouldn’t you think it could actually boot?

Worst case, do you suggest I simply wire up a UART?

Also, my system did not even appear to cross the boot stage (red and blue solid lights). Even if the OS had a problem wouldn’t you think it could actually boot?

What is the image file name you are flashing? Are you sure it ends with +model.img.xz? Le Potato is aml-s905x-cc.img.xz.

Worst case, do you suggest I simply wire up a UART?

UART will tell you that it didn’t find the bootloader.

Hello Mr. Libre,

I tried with the correct image from the CI, and it works! Thank you so much.

1 Like

What is the baud rate for s905x for UART? I read on other forms that some PL2303 chips for uart may not work with these boards as well so I am trying to find out what my issue is while debugging.

1 Like

This helped me so much! Thank you!

1 Like

I have le potato (s905x), installed raspbian os on sd card (no gui) and enabled ssh. I have a wifi dongle connected and whenever I connect my external hard drive it does not boot up or more accurately I cannot shh since it has not booted up. I can see that the wifi dongle is not lit up and the eth port does not light up as well. If I disconnect my external drive it works fine. and if I connect the drive afterwards it works fine as well. I’m looking to boot up from my sd card and have the external drive for nas even on reboots. Any suggestions on what I’m doing wrong? Does it not have enough power going in? Or is it the boot sequence somehow getting messed up?

Please read the original post pertaining to power and external drives.

I’m guessing you mean that it needs a powered usb hub in between the drive and the board. Will try out and post here on the results.

MicroUSB can deliver enough power for the board and some small peripherals. It’s not designed to power external drives and other high power devices.

Mine is external drive with its own power supply. Will it still not work?

If it is externally powered, it will work.

I recently purchased two ROC-RK3328-CC boards (to experiment with clustered computing) and I have been struggling with the “red & green solid lights” and not being able to boot.

I finally got it working a few minutes ago and wanted to contribute. :slight_smile:

I am using the following SD card: PNY 128GB Premier-X Class 10 U3 V30 microSDXC Flash Memory Card - 100MB/s, Class 10, U3, V30, A1, 4K UHD, Full HD, UHS-I, micro SD.

Couple things… I am running Ubuntu 22.04.1 LTS on my laptop. I used a “Uni” adapter (one end USB 3, the other end, USB C, and you can insert the Micro SD card in the middle) to format the Micro SD card. I used the ‘Disks’ OS utility to format the Micro SD card.

I installed the ROC-RK3328-CC-Debian9-Arch64_20180525.img OS image on the Micro SD card, using the recommended Etcher utility (‘balenaEtcher-1.13.1-x64.AppImage’).

For power, I’m using my Pixel 6 Google 30W USB-C charger and a new USB C to Micro USB cable. At first I thought the board may not have been getting enough power but I got past that with a pretty basic phone AC adapter.

My green light went away after boot (no “heart beat”), red light was solid, and I was pleasantly surprised with the Debian desktop when I plugged the HDMI cable into my monitor.

I believe my issue was simply related to the formatting and partitioning of the Micro SD card.

Hope this helps someone else. Thanks.

You can use the standard Ubuntu or Raspbian images. Currently upstream u-boot doesn’t support HDMI but it will soon. So it just takes about 30 seconds before you get video on ROC-RK3328-CC Renegade.

Sounds good. Thank you!

Hi, this is basically the same email I sent to on 06JAN2023 (there was no reply)

I received my SBC Renegade late last month (Brazilian postal service was slow) and have only now been able to start using it

I am running into a problem in getting the Renegade to work: it seems that it does not boot - I have:

  • flashed 3 different SanDisk Ultra microSD UHS-I cards with 3 different firmwares using 3 different Flashing tools (following your site’s instructions)

  • used 3 different power supplies (including a 5v/18A PC power supply – voltage between GPIO pins 1 and 6 is around 5.10v)

  • attached 3 different HDMI monitors (these all worked for Raspberry Pi’s 1 and 3)

-connected a 3.3v CH340 USB serial adapter to GPIO pins 34,36,38 (using PuTTY on Windows, 1,500,000 / 8 / 1 / No Parity / No Flow)

The results are always the same:

  • both red and green LEDs light (solidly, do not blink)

  • no video signal whatsoever (all 3 monitors)

  • no activity at all on the DEBUG GPIO USB serial adapter

  • power consumption is always around 200 mA (no change)

Also, all above (MicroSD cards, flashing tools, power supplies, HDMI monitors all work with Raspberry Pies 1 and 3)

So, I am wondering if I received a bad board or something else

Can you please let me know if there is a way to test the board (test routine / jumper combination / ???) before calling it a brick and requesting a replacement board?

Please let me know what are the next steps that I should take

Thank you for your kind attention and help

Sincerely, John Svendsen

Most likely you did not flash the image correctly or flash the correct image on your MicroSD card.

From all what I’ve read throughout the posts about booting issues, it is my undestandng that the green led blinks when the microsd card is being accessed - or have I missunderstood the green led’s behaviour?