After first boot

I did the image writing to the SD card, I put the wpa_supplicant, userconf.txt and the ssh files in the head boot directory.
I then connected it to the power, it booted, the green LED is working, but the router showed no new connected device.
I connected the ethernet cable, and the device is now pingable, but I can’t connect to it via ssh, the connection is refused.
so, I powered it down, copied the same files to every directory in the sdcard, but still the same thing.
And I noticed that the SDcard is still partitioned in a small boot partition and the rest is not-partitioned , and that means the OS didn’t auto expand.

So, I’m wondering what should I do next.

NOTE: I don’t have a monitor to connect it to, I was hoping I can get it running headlessly via ssh.

Thanks in advance.

Edit: I moved the files to the parent directory, and it worked, now I’ve successfully connected to it via ssh.
Now, should I run some script for installing and auto-expand?

What is that? The files belong in the EFI/FAT partition.

The post is edited, I mean the main directory.
Now it’s working, I’m able to ssh to it.

Is there any script that I should run?

The image auto-expands by itself on first boot. What script for what purpose?

it’s done.
but what is the default root password ?

Please read the release notes of the image you picked. Different distributions use different defaults. Or use the search function.

1 Like