AML-S095X-CC memory error on boot leading to boot cycle

I’m getting an “invalid memory at 0x000000005a8a7028” error when trying to boot. It goes into a cyclical reboot cycle. I’ve tried different microUSB cards, have sufficient power supply, flashed using the recommended steps, etc. as described on the troubleshooting boot issues page. Is my hardware bad? Below is the log I pulled from the boot.

EFI stub: Using DTB from configuration table

EFI stub: Exiting boot services…

“Synchronous Abort” handler, esr 0x02000000
elr: ffffffffdd460210 lr : ffffffffdd460200 (reloc)
elr: 000000005a2e1210 lr : 000000005a2e1200
x0 : 000000005a8a7028 x1 : 0000000000000000
x2 : 000000005a8a7028 x3 : 0000000000000028
x4 : 0000000000000028 x5 : 0000000000000000
x6 : 000000005a8a7000 x7 : 000000007be8d000
x8 : 0000000000000000 x9 : 0000000000000000
x10: 0000000000000007 x11: 000000007be8d000
x12: 000000007ae59268 x13: 000000005a353254
x14: 000000007be648c0 x15: 000000007be648a4
x16: 746f6f7220353735 x17: 61623d444955553d
x18: 0000000000000004 x19: 0000000058c20000
x20: 000000005a8a7000 x21: 000000005a8a5040
x22: 000000000000b400 x23: 0000000000200000
x24: 000000007be648a0 x25: 000000007be9e410
x26: 0000000000000000 x27: 000000000000b400
x28: 000000007a9fd1b4 x29: 000000007be64780

Code: b5000083 12800041 2a0503d9 a8c17bba (d503236e)
UEFI image [0x000000007a9e1000:0x000000007ab9ffff] ‘/efi\boot\grubaa64.efi’
UEFI image [0x0000000058e20000:0x000000005a89ffff] pc=0x14c1210
Resetting CPU …

Have you tried with any other images?