AML-S805X-AC La Frite How to Update Board UEFI BIOS Firmware

Good improvising! Glad it worked for you.

Hello,
First of all thanks for all your hard work.
I’m trying to upgrade my board firmware with u-boot-2021-07-r1.bin but I found the script (u-boot-2021-07-r1.scr) is trying to get the old firmware file name (u-boot-2020-07-r7.bin) into it.
Also I found the links into README.txt are outlated.

Once again,
Thanks!

Follow the OP. The instructions you are referring to are not relevant and were created in 2019.

Sorry, what OP is?
Anyway, I think the information into Index of /board/libre-computer-project/libre-computer-board/aml-s805x-ac/firmware/ can be updated.

Original post. The top post on this thread. Do not use anything from that link.

Oh, ok.
Now I see, when I search for firmware (into the search box) this post is the first one I get. Then the correct one is Libre Computer Board Firmware Update Images, right?
Thanks!

Ok, now I’m getting this error

We updated the spiflash image to account for your issue. Can you please test it and let us know if it works for you?

Hi! I tested this new spiflash. It boots and ran the flasing process but ends with and error, unfortunately I didn’t take a picture. Now if I press a key during the boot process I get a prompt (uboot prompt?) Then I think the flashing process worked, also I don´t see the LOST menu anymore. One more thing, when it boots from emmc, after the grub menu the monitor remains black, like it hasn’t video signal.

We got rid of LOST because it needs some updates. We will launch V2 around the end of the year.

1 Like

Hi there!

Thank you for detailing your journey!

I am probably in the same boat you were - however I fear that I corrupted the SPI flash while trying to update the old u-boot-2021-07-r1 to the version as of 3rd of November by removing the -v options in the .scr file.
I am able to get into the debian grub menu as well as starting a boot.scr script utilising boot.py - but I am not able to flash a new SPI image or boot an operating system with HDMI output as of now (however I only ran limited tests until now).

Did you have any success booting an OS that can be somehow accessed (preferrably via HDMI output but also possible via SSH session)?

Hi @skyfall !! yes, I think we are at the same place. I’m still have a working OS because it was already working into an emmc, and I’m not using HDMI, just accessing via SSH.
I’m also not sure how I’ll be able to flash a new SPI image.
I’m able to access the emmc card using the boot.py utility.
I think you may try using a USB-TTL usb adapter to connect to the board console and you should be able to write a the OS login prompt.

How did you guys get to the links for the outdated SPI image?

Hi @librecomputer I’m really not sure, but looking at my browser history I found the following link

At the bottom of this page you{ll found the link to Index of /board/libre-computer-project/libre-computer-board/aml-s805x-ac/firmware/
But let me mention the problem we have now, started after apply the latest SPI image https://boot.libre.computer/ci/aml-s805x-ac-spiflash

1 Like

:eyes: Thanks to @librecomputer pointing this out to me, the Armbian download page has been updated, I don’t remember the instructions for that being there…

1 Like

I installed the u-boot-2021-07-r1 back when it was new and had the SBC running since then until last month without any issues.
On November 3rd I then tried to update the SPI to the newest version in order to reuse or resell the SBC.
However, I did not yet have time to test reflashing - would it be possible to use mtdutils or similar provided I could “manually boot” a debian/ubuntu image using boot.py?
As @sserantes pointed out, serial access and/or SSH should be possible - I haven’t yet tried that.
I’ll try to take some time in the next two weeks and report back.

You can but we don’t support that mechanism.