AML-S905X-CC (Le Potato) 480x320 ILI9486 3.5" SPI Touchscreen Display

Now I’m using the ubuntu base image and I cannot get it working as well, I’m using sway compositor.

Weston works out of the box. Not sure why Sway would not work for you.

1 Like

I tried weston as well and I have the same issue, was weston tested on the base image or the desktop image?

True, in my case it does not work on any of the images…

Weston is available on the server image. Just login and run weston.

1 Like

I downloaded the server image “ubuntu-22.04.1-preinstalled-server-arm64+aml-s905x-cc.img” and did the following:

sudo apt update
sudo apt upgrade
sudo ldto enable spicc-cs1
sudo ldto enable spicc-cs1-mpi3501

and still did not work, the screen is just white. it worked with the desktop image so I don’t know what am I doing wrong.

Read the OP in full. After enabling the screen permanently, reboot and then run weston.

it worked now :D, I never actually tried enabling the screen permanently, maybe if I had it would have worked on the other distros, thanks.

Another issue I have identified is that when using the Touchscreen, the CPU usage increases up to 30% and things are very slow, the screen lags and freezes sometimes, I remember it happening on the ubuntu desktop image as well.

SPI displays are not fast. Your software needs damage tracking for optimal performance. If you want good display performance, use HDMI instead.

Any updates? When can we expect it to be fixed?

Expect what to be fixed?

Hi. Related to the earlier topic.

I’m running Lakka and I’d like to modify the OS on the Le Potato to use the library you specified earlier for the 320x240 screen:

Can you help me by providing me with a starting point to figuring out how to do this? I do not know how what is meant by “copy the overlay”.

I’m only interested in the visual display as well, I don’t care at all about the touchscreen functionality.


Any thoughts/ideas on this?

You have to merge the overlay into the device tree that Linux uses.

The board boots up u-boot and then read a device tree binary file (dtb) and passes that to Linux. You need to use the device-tree-compiler (dtc) to convert the device tree binary to device tree source (dts) and then merge the overlay using using fdtoverlay. Copy the resulting file back where the device tree binary was on the Lakka image. There might also be additional setup.

This explains the basic mechanism but it might be more complex than this since Lakka image uses an old 5.10 kernel. Once we finish the Linux 6.1 migration, we will be re-releasing Lakka and other retrogaming images that will incorporate and work with the normal ldto tooling.


Thanks for the response. I’ll go asking around some linux forums to see if they can give me some advice on how I could make it work on the 5.10 kernel. Even if I can’t get it done, I’ll learn something along the way and it’ll give me something to do while you guys figure it out.

I have tried all of this and still a white screen of death, anything else? I have the MHS-3.5 LCD and running bullseye.

  1. Did you move the jumper?
  2. Attach photos of your board without screen.
  3. Run sudo ldto reset && sudo reboot and after reboot, run the commands in the OP.

I have, here are the photos

Re-did everything again, started to boot showed some boot text the instead of white screen now it stays black