AML-S905X-CC (Le Potato) Boot Issues on 2 new boards

Long story short. I ordered 2 pack AML-S905X-CC (Le Potato) from the USA on Amazon UK for delivery to the UK. They arrived surprisingly quickly and hassle free. I bought them to run Pi-Hole. I currently have Pi-Hole running on a Raspberry Pi 3B, but wanted to run 2 instances, so unable to actually get hold of any Raspberry Pis for such a long time, checked out the alternatives and settled on the AML-S905X-CC (Le Potato).

I also got 2 new Official Raspberry Pi Power Supplies (5v 3A, 15.4 Watts). I downloaded Rapbian 11 Bullseye images (2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img.xz and 2022-09-22-raspbian-bullseye-arm64-lite+aml-s905x-cc.img.xz) from the Libre Distro Server.

I ordered some SanDisk Extreme Pro 32 GB microSDHC Memory Cards and already had some SanDisk Ultra 32 GB Micro SDHD cards.

I followed the guidance to install the OS, formatted the SD Cards with SD Card Formatter, and imaged with Win32DiskImager. All of many attempts using different SD Cards and different Windows 11 PCs Wrote the image Successfully, but all immediately failed “Verification failed at Sector: 8192”.
So I imaged using RaspberryPiImager and it Verified OK.

I plug the SD card into the AML-S905X-CC (Le Potato), plug in Ethernet, Mouse and Keyboard and power up, but it does not boot successfully. It starts to boot, flashes up the following, and then reboots, and cycles round this continuously:

I try to build a bootable SD Card, using both AML-S905X-CC (Le Potato) and 5 different SanDisk SD cards, and different imaging software, including BalenaEtcher. I also tried with a Ubanto Image – Same Result!!! All results the same!

Wondering if it is a power issue, I unplug everything and try all sorts of different combinations, and eventually discover that it will boot properly on both boards, with all 5 SD Cards, IF the Keyboard is not plugged it, and will work fine if the keyboard is plugged in after boot has completed.

So I order an expensive 5v Power supply, an Anker USB C Charger, 726 Charger (Nano II 65W), which has oooodles of power and headroom. SAME Issue!!! So the problem is not power (Reading 5.01V on GPIO Header).

Now in my initial requirement, running Pi-Hole on a Headless board, it is not such a problem because it will work, but it means I will not be buying any more Libra SBCs unless I can fix this problem, and most applications will require a screen, keyboard and mouse as well as ethernet.

So I attempted to update to latest software:

sudo apt update

and when it had finished:

sudo apt upgrade

At the end of the output there was this:

…but the board reboots OK (headless) and pi-hole still runs OK on it even though it says bootloader not properly installed!

Maybe this help diagnose the problem, but I am now completely lost!

PS. The image installed is the lite version as it is to be a headless DNS server, but same boot issue results on full version.

Any chance of some help or guidance from @librecomputer regarding my issues, please?

OK Update: The Booting issue with keyboard plugged in to USB is resolved;

I “borrowed” the Logitech keyboard from my wife’s PC and it has resolved the problem, both boards now boot OK with monitor, ethernet, mouse and keyboard plugged, just as they should!!! this was with the same SD card and image build that was failing, so it was not an imaging, power or SD card issue.

It seems the cheap “Advent” keyboard I bought as a spare for this sort of temporary/backup use somehow kills the AML-S950X-CC if plugged it when booting.

I still have the issue that upgrading the OS fails, so I reformatted the SD cars and re-imaged, and installed Pi-Hole and once it was up and running, performed the;-

sudo apt update

followed by;-

sudo apt upgrade

and still got this;-

But it all is working as a pair of Pi-Hole DNS servers anyway.

What is the upgrade error issue, can anyone help please?

The error (grub-install cannot write EFI variables) is not consequential. You can safely ignore it.

OK, thank you, in that case I will deploy the pair live.