AML-S905x-CC (Le Potato) fails to boot

Firstly Hi All! Apologies for the crappy title, isn’t very descriptive at all on whats going wrong. I will do my best to provide all information to allow for people to help me identify the problem. I am new to the micro-pc world, never thought I would ever have a problem booting into an OS. If the issue is something that an organism greater than a potato could handle, I will gladly accept my fate of being the potato of potatoes.

Board:

  • “Le Potato”
  • “AML-s905x-cc”

MicroSD Specs:
2x Samsung 64GB EVO Plus A1 V10

  • Read the guide, says that sandisk and samsung are ideal, especially with A1 rating.
  • Brand new, so no signs of aging from continuous rewriting (no dying microsd cards)

Explanation: (How far I’ve gotten, in the listed offical normal order to the boot sequence)

  1. Extracted the .img file from the .xz archive with 7zip
  2. Taken the .img file and used “balena etcher” on linux to flash img to microSD
  • I tried to use the win32-flash tool you guys, and followed the provided youtube tutorial disabling automount with administrator privileges. The write aspect of the program would work, but the verify would fail, with the “Error: 2048”. I didn’t believe that the drives were failing already, so I suspected it was a problem with the operating system permissions, and switched to using balena etcher in ubuntu.
  1. When the flash (write and verify) was completed successfully, I ejected the microSD card and inserted it with the correct orientation into the slot underneath the board, and powered it on.
  2. Power is not an issue, as I am using an adaptable power supply, capable of supplying the potato with sufficient power (5v 1.5amp minimum)
  3. Blue & Red Light ON: Libre computers screen would appear, with some lines of text (assuming that it was initialising the boot sequence)
  4. Blue, Red & Green Light On: Linux Grub screen would appear, with the options “Linux” & “Advanced options for Linux” (2nd one was something along the lines of that)
  5. Red & Green Light On: After 3 seconds, it would pass, and this screen would appear, (like it was doing something, but it wasn’t (like infinite buffering in a video, but the boot was stuck) (in support, it says that first boot can take upwards of 2 minutes, but I left it on in the hopes that my ssd was just slow, and unfortunately the screen didnt change after an hour. (I suspect that it is because there is some sort of error which causes the boot to freeze, as the blue led which is supposed to indicate activity, and it turns off, that may indicate something breaking during the boot.

The screen in question:

Potentially Important Details to note:

  • Only things that were plugged in were the “Micro usb cable” for power, the “HDMI cable” for viewing, and an “ethernet cable” connected to the modemn. When boot was attempted with further peripherals plugged in, the device boot loader wouldnt even start, until I unplugged the kb&m.
  • When I attempted to replug them after I got the boot loader started, they wouldn’t respond to input in the grub menu, no matter what I did.
  • Thinking it may be a power issue because I have an rgb keyboard, I swapped it out for a magic keyboard (apple keyboard with cable), and that didn’t halt the boot process, but did however still not work in the grub menu.
  • I plan to use this as a ubuntu server so I dont intend to have kb&m or monitor plugged into it (just ssh remotely), just tethered to the outside of my modemn so I can connect a ethernet cable to the back of it.

This may be the longest request you’ve ever seen, reason so the more information I provide the easier it will be for people to determine the cause. As it is entirely optional for anyone to help me out, if you do take the time out of your day to lend a hand just know I would greatly appreciate it!

Extra Bonus Bit: I took a break from messing with “Le Potato”, and decided to work on the main board I bought (ROC-RK3328-CC (Renegade)), Used the exact same method I described in all of my steps (same everything except only variable is the board, and it works. (Not sure if Im just missed the most little piece of extra information in regards to “Le potato”, but if someone reading this knows please let me know)

What are you using for a power supply? Have you tried a different one? Are you using the same supply for the renegade?

Same one for the renegade, renegade works and is fully operational, potato fails after grub menu. I’ve also tried multiple other ones with my renegade, all working.

I’d recommend using TTL Serial communication to debug boot issues. It provides more information and additionally a history of the boot sequence logs via the second device. Le Potato has 3 labeled UART pins specifically for this purpose between the HDMI and micro USB power.
The recommended USB adapter cable is this 3.3V USB UART Serial debug cable.
I’ve also found this multi-voltage USB to TTL UART Converter Chip pretty handy as well.

I recently had this happen during a boot of Debian on a Le Potato - copied here directly from a PuTTY terminal over the USB/Serial device on my Windows PC:

[...]
Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... Scanning for Btrfs filesystems
done.
Begin: Waiting for root file system ... Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
[...]
Begin: Running /scripts/local-block ... done.
done.
Gave up waiting for root file system device.  Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT!  UUID=ae802f12-183e-4db5-b8a1-d70eba710416 does not exist.  Dropping to a shell!
[...]

Seems the root partition couldn’t be read. I reapplied power and booted up without issue.
Unfortunately I didn’t have the foresight to check via HDMI if that additional info and shell was also available over tty1.

Well, I can confirm now that this happens whenever I send a reboot command on my AML-S509X-CC, and doesn’t happen when I boot by applying power.
Additionally a secondary USB drive doesn’t mount correctly via fstab on that first boot (bind mount from inside the mounted block device) - I have to log in under recovery mode and mount -a to mount them. The same setup works fine on a Renegade ROC-RK3328-CC, except with a different microSD card/brand (SanDisk Extreme on Le Potato; Samsung Pro Plus on the Renegade)
Seems like some funky firmware mishaps, and not sure if it’s just for the latest Debian 12 image. I checked both microSD and USB for bad blocks (via Rufus) and came up with none.
I’ll try with another USB and microSD at some point - for now I have some other boards and services that need running.

I’m seeing the same problem on my Potato. Boots fine when I disconnect and reconnect power, doesn’t come back up when I reboot. I’m also running Debian.
One thing I can add is that this doesn’t happen for me when booting from emmc, only from SD

Switch SD cards. The SD card you are using does not reset correctly without powering down completely.