AML-S905X-CC (Le Potato) HDMI black levels washed out

I have been using the raspian image and recently changed to an oled monitor and very noticeable that black levels are limited with washed out blacks. I do not see “Broadcast RGB” as a property in xrandr and I cannot set it to Full, I tried editing edid.bin files based on tutorials and I can see changes in edid printed by xrandr, but still getting washed out blacks. Is there a way to get Full RGB output from HDMI with Le Potato?

For embedded devices, most of these settings are configured in the kernel in drivers/gpu/drm. There may not be userspace parameters associated with colorspace depth and other changes due to the clocking setup to generate the target frequency. You would have to recompile the kernel to force certain modes and possibly setup some clocks.

The general selection of the mode to use for a display is controlled here:

Under the meson subfolder are viu specific setup of clocks.

What is the make, model, and EDID of your monitor?

The monitor of interest I want to get working is an innocn OLED monitor I got off amazon. Decoding the EDID reported out of xrandr gives the following for make, model info:
Manufacturer: IOC
Model: 5472
Display Product Name: ‘15A1F’

Testing with an LG OLED TV I get the following:
Manufacturer: GSM
Model: 49352
Display Product Name: ‘LG TV SSCR2’

With both displays I can get full black levels on my personal computer, with Le Potato both have washed out black levels.

The full EDID for the monitor I want to use with the Le Potato:

Can you try CoreELEC to see if you can tweak the setting from limited RGB to full RGB?

I have made several customizations to the OS to get it working for my needs, switching distros would not be a desired fix.

Looking at the kernel repo you linked, I think the file of interest would be:

And hard coding it to use FULL_COLORIMETRY_MASK, though I’m not 100% confident in that, nor have I ever built a linux kernel, so I could pull the repo and make changes, but wouldn’t quite know where to go from there.

I just tried CoreELEC using Le Potato, I am getting limited RGB and I see no way in their UI how to change it and not familiar with any utilities included in CoreELEC. Tried a Pi 4 I had and it properly displayed Full RGB with a fresh raspbian install with no changes.