Are there Pre-compiled Kernels available for Debian 11 (Non-Raspian) with Hardware fixes for AML-S905X-CC (Le Potato)?

I installed Debian 11 using the Netinst ISO method described in your presentation linked Here on my AML-S905X-CC board. MicroSD (no eMMC Module yet, maybe someday I’ll have some extra pocket money)
In one of the final slides, you recommend updating to a newer kernel with ethernet and media acceleration patches. I tried using that kernel and had many more issues (Such as boot/ethernet issues, Docker and other services failing to start, etc.) and had to go back to the standard kernel installed with debian (5.10.18 or 5.10.19).

However the kernel installed by default doesn’t appear to have certain thermal sensor flags enabled, so I can’t get the board temperature which i want to use for some automations. (I’m using the vanilla debian install to run a home-assistant “supervised” setup that isn’t supported on other flavors)

I wanted to see if you have some pre-compiled kernel packages like the one in the slide, that have perhaps been updated since that date of publication? I saw some test kernels mentioned in your twitter and then saw you posted about Ubuntu running on a newer 6.0+ kernel.

I realize I could potentially compile the kernel myself from the github source, but it’s not a process I’ve completed before so there are a lot of variables down that path.

The Raspbian images are basically stock Debian images. You can use them in place of Debian for 99% of applications. It uses our latest kernels and bootloaders.

Since Raspbian 11, it uses Debian for underlying packages with very few non-Debian packages that do not affect much.

So no easy way to “steal” the packages from those images?

Homeassistant is fairly restrictive on the requirements for the Supervised Install and tend to detect any deviance and put up an obnoxious “Unsupported” Notice in the main system info.

You can point it to deb.libre.computer and get the kernels but Raspbian even advertises itself as Debian so there is no difference between Raspbian and Debian images. It should look like a stock Debian 11 ARM64 install to HA.

Thank you!

I added “deb Index of /repo/ linux main non-free” to my /etc/apt/sources.list, manually imported the GPG key, and installed and booted kernel 5.19.17-00330-g3d20c75b4d06

I was still having issues when rebooting. I had to unplug the network cable and then reconnect it after it completes booting, otherwise I got logs showing it repeatedly resetting the network adapter.

I went ahead and tried linux-image-6.0.9-00871-g154f6a944845 and after a couple reboots everything seems to be golden!

Yes it is best to keep track with our kernel updates as we discover and resolve issues users report. Once Linux 6.1 rolls around, it will be LTS and you can track that per Linux Kernel Policy