Best OS to get up and running with AML-S905X-CC?

What is the best operating system to get up and running with the AML-S905X-CC board? I have tried several different images but I am having a few issues.

I tried 2 different Armbian images:
Armbian_22.08.9_Lepotato_jammy_current_5.10.147_xfce_desktop.img.xz
Armbian_22.08.8_Lepotato_jammy_current_5.19.17_xfce_desktop.img.xz

For both of these the board would not boot and the green light never came on. I tried burning them to SD a couple of times each without any luck.

I also tried version 10 of Raspian:
2022-09-22-raspbian-buster-armhf+aml-s905x-cc.img.xz

This images loaded, let me set location and downloaded updates. When the system rebooted it ran into issues (possibly with the filesystem) and would not load. I tried this process multiple times with the same result.

I have had the best luck with Raspian 11:
2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img.xz

This image is the only one that runs and updates without issue. I am trying to use it now over VNC viewer and running into issues. The Raspberry Pi config from the desktop does not work so I can’t change display settings. I have tried several things on the command line but can’t increase the display size beyond a very tiny view. I have started trying things with ‘tvservice’ and ‘vgencmd’ but I am getting ‘VCHI initilization failed’ so they are not working. Based on some research it looks like this might have something to do with kernel settings.

My question is, what is the best and most tested OS image to get past basic config issues so I can start doing development with the board? Is there a specific OS that has received the most testing and development so I can be relatively certain I won’t have basic issues and will be able to start programming on right away? I am open to using a different OS I just want to know what is the most stable and will work the best.

  1. Armbian is broken right now. Use official images.
  2. Raspbian and Ubuntu should both work. Filesystem errors are usually because your MicroSD card is dying and corrupting data. Our images have strict checks for filesystem corruption and will switch to read-only mode if it detects MicroSD card failures to prevent data loss. Armbian and Raspberry Pi’s don’t do this.
  3. Don’t use Raspberry Pi instructions for anything on our boards. They don’t work. To change screen resolutions, just right click the desktop, go to display settings, and change the resolution there. Treat our products like regular PCs and follow regular Ubuntu instructions.
  4. This is an upstream Ubuntu bug when using wayland not specific to our images. You have to switch back to X11.

@librecomputer I just created another thread and then found this. I’m running into the same iseue with Rasbian. After completing a brand new install I run “apt-get update && apt-get ugprade”. Installs fine, after a reboot, the system will not boot.

This is not a MicroSD issue on my end as we are running higher end Samsung MSD (tried three different cards) and they are all brand new.

Any ideas?

Replicated the problems. They are fixed and the CI should push new images to the server within the next 12 hours.

This was specific to the Raspbian 10 images. The crappy Raspberry Pi partition resize script changes the disk ID but fails to update fstab. We moved fstab to mount via labels instead.

The new images are being synchronized with our S3 buckets. Please download the images in 2 hours.

I’m going to ask the same question but a different way. I’ve spent three days fighting with various OS versions to get wifi (rtl8811uc) and i2c busses working, none of them successfully. Is there an OS for the Potato in which a wifi dongle (I don’t care which one it is) just works out of the box…and where the I2C bus “just works” like with the Rpi out of the box.

It would be nice if Libre created a current list of hardware (like wifi dongles) that “just works” with various OS’s that you distribute. As well, if something requires special configuration some old fashioned Linux type “How-To” documentation would be priceless. I have no clue what this I2C overlay magic is that I have read about but sure seems like you could build in a PI option into a setup script that just set the GPIO pins like the Rpi for those of us that need it.

Realtek never upstreams their WiFi drivers. MediaTek chips are good MT7601U MT7610U and MT7921AU which are all plug and play.

For I2C, see the libretech-wiring-tool page on this hub. It tells you how to enable and which pins.

All of our kernels are the same across all images so if it works on one, it will work on all. If it doesn’t work on one, it doesn’t work on all. There is no need to check every image. This only applies for images on our distro server. Other images released by third party may be different.