Can't get xorg to run on le potato

Running ubuntu jammy/22.04. Setup all the basics fine, installed kde plasma, sddm, etc.

However, Xorg appears to not start, and I’m not sure how to get a graphical interface on these boards outright.

The end of our Xorg log indicates:

[    16.062] (WW) Falling back to old probe method for modesetting
[    16.078] (II) modeset(0): using default device
[    16.078] (WW) Falling back to old probe method for fbdev
[    16.079] (II) Loading sub module "fbdevhw"
[    16.079] (II) LoadModule: "fbdevhw"
[    16.080] (II) Loading /usr/lib/xorg/modules/
[    16.089] (II) Module fbdevhw: vendor="X.Org Foundation"
[    16.089]    compiled for, module version = 0.0.2
[    16.089]    ABI class: X.Org Video Driver, version 25.2
[    16.090] (II) FBDEV(1): using default device
[    16.095] (II) modeset(G0): using drv /dev/dri/card0
[    16.095] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    16.095] (EE)
Fatal server error:
[    16.096] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[    16.096] (EE)
[    16.096] (EE)

I ran Xorg -configure, as used to work back in the day, doesn’t appear to indicate available hardware. Do I need a special driver for Ubuntu somewhere? Should I be running wayland or something else directly, instead? I feel like I’m missing something trivial; I haven’t used a ‘desktop’ linux box since long before wayland existed.

Just use the desktop image off the Libre server? I think I get why you’d want to install everything from base, but if you just want a GUI that is the path of least resistance.

We recommend using Armbian if you want to use pre-configured Xorg desktop.

Our images are designed around wayland since X11 does buffer copies and eat up the RAM bandwidth on these boards.

Any update on this? Building a kiosk so installing a full blown desktop is out of the question.

I’ve managed to rebuild my kiosk install scripts using wayland (weston). Problem solved.

1 Like