CEC-Client errors

If I attempt scan HDMI CEC I get:

cec-client -s

  • failed to open vchiq instance

I found a blog post online that you need to add your user to the video group for permissions, so I did that and rebooted but still didn’t work.

vchiq is Raspberry Pi specific and not under Linux’s general HDMI CEC infrastructure.

1 Like

Is there a library to use HDMI CEC that works with Le Potato instead of cec-utils/cec-client? Or do I need to enable the hardware inside of Armbian and Rasbian?

If I run cec-client -l I get

libCEC version: 6.0.2, compiled on Linux-4.15.0-166-generic … , features: P8_USB, DRM, P8_detect, randr, RPi, Exynos, AOCEC
Found devices: NONE

What board are you using and what image are you using?

sudo cec-ctl
Driver Info:
        Driver Name                : meson-ao-cec
        Adapter Name               : meson_ao_cec
        Capabilities               : 0x0000011e
                Logical Addresses
                Transmit
                Passthrough
                Remote Control Support
                Connector Info
        Driver version             : 6.0.11
        Available Logical Addresses: 1
        DRM Connector Info         : card 1, connector 34
        Physical Address           : 3.0.0.0
        Logical Address Mask       : 0x0010
        CEC Version                : 2.0
        Vendor ID                  : 0x000c03 (HDMI)
        OSD Name                   : 'Playback'
        Logical Addresses          : 1 (Allow RC Passthrough)

          Logical Address          : 4 (Playback Device 1)
            Primary Device Type    : Playback
            Logical Address Type   : Playback
            All Device Types       : Playback
            RC TV Profile          : None
            Device Features        :
                None
1 Like

AML-S905X-CC (le potato)

Armbian 22.11 Jammy
Kernel 5.19.y, Size: 512Mb, Release date: Nov 30, 2022

Failed to open /dev/cec0: No such file or directory

I have the jumper closest to the micro USB power plug set in the default position away from the board edge. Which I believe is CEC vs GPIO.

Armbian does things differently than how we do our images. Please use the Armbian forum for those images. Our images are more optimized for and tested against our specific boards where as Armbian is more generic support.

Correct the jumper should be set away from the edge of the board.

1 Like

Which image do you recommend that has working CEC? I downloaded it off of this page.

https://libre.computer/products/aml-s905x-cc/

I tried your Rasbian Bullseye distro first and it errors the same.

I’m happy to use any distro since CEC is the primary feature I’m hoping to use the board for.