Debian Bookworm Gnome - 1366x768 Support

I’m currently using Debian 12 Bookworm Gnome on a Renegade and it’s running better than Armbian Bookworm Gnome, the only issue I have is getting the display resolution to either scale or match the display it’s connected to which is 1366x768 whether on Xorg or Wayland. Is this something that would be supported in a newer kernel, and if so would any updates be coming soon?

Are these posts by @butonic helpful to you at all?

Thanks for these I will take a look.

Thanks AltaTHD,

Unfortunately this didn’t offer any new options, I have been trying to scale, transform and even add new resolutions with xrandr which has worked in the past including on Raspberry Pi OS for the Renegade but so far no luck. It’s not the worst thing in the world, I just have a resolution that’s too big and crops off of the screen, or 4:3 that fits inside the screen.

Hi @littlerobot,

Sorry to hear that didn’t help but thought it might have been worth a try!

I hope someone else can assist you further; having stuff off-screen is really unhelpful in some situations…

No worries I appreciate the help, if anything it was useful information.

1 Like

1366x768 should be a supported resolution, just not in u-boot bootup. It should work when it gets to Linux per AML GXL No Video or Bad Video on Monitor - #50 by Xylopyrographer

Thanks for the response, are you saying that after the OS boots up that the 1366x768 should be available? I’m currently using 1024x768 because 1366x768 is not available after boot as far as I can tell. This monitor works in 1366 when I run Raspberry Pi OS or Ubuntu 22.04 on the Renegade.

We use the same kernel on every board. If it works on one image, it should work on all. Just update your kernel and try it. I thought you were using Le Potato. That link shared in the previous post is wrong.

I updated the kernel but now the Renegade won’t boot. Not sure what to do at this point, I’ll post any updates.

Won’t boot Linux or won’t boot anything?

Won’t boot into Linux, I get some text then it stops loading/scrolling, there is a message about a cat file and a UUID that doesn’t exist it’s a little hard to read since the text is cropped/overscanned.

It’s hard to tell since the screen is cropped off but it looks like it’s in BusyBox. From here I’m trying to manually load a kernel, I tried looking in /lib/modules I might try this on a different monitor because it’s still hard to read, any tips would be appreciated.

Here’s a little update,

I was able to successfully update the kernel from 6.1.74 to 6.1.87 using the following commands:
#to check for kernels
apt-cache search linux-image

#to install
sudo apt install linux-image-xx

This worked with disabling OS Prober as well as leaving it as is, the commands are:

#modify the grub file
sudo nano /etc/default/grub

#uncomment or add GRUB_DISABLE_OS_PROBER=false

sudo os-prober
sudo update-grub

After this reboot.
Both approaches worked.

This update did not change anything in Wayland or Xorg from what I can see.

I tried to update again to linux-image-6.5.9 which is the first that left the Renegade unable to boot, again same result even with disabling OS Prober and updating GRUB.