Having strange failures with AML-S905X-CC


I’ve had two older AML-S905X-CC boards that I’ve used for a while, have used them a lot lately and like them. These were using SanDisk 32GB A1 SD cards. Worked well. Here recently I bought 5 more AML-S905X-CC boards with heatsinks and USB wifi. I’m having problems with these new boards.

The new boards have colored GPIO headers, that’s a nice addition. With the new boards, I’m using 5 new SanDisk “ExtremePro” 256GB A2 SD cards. I’m coming to the forums here because I think the odds of multiple of these all having the same issues is slim.

I’m using this image for the new boards:

First board that I powered up, I updated the OS and started installing various packages. I was getting “read only” errors from the OS periodically. When this happens, the OS is no longer able to read the SD card at all. For example, I couldn’t use commands like “clear” or “vim”, it would say command not found. I would power off/on and the issue would go away for 5 or 10 minutes, but would come back. I have tried re-seating the SD card while it was off, but still the issue would come back. Eventually re-wrote the image to the SD Card and that one is acting OK now.

Second board, the issues are similar but worse. Periodically, the board will give the same problems, being unable to read/write to the other new SD Card. And upon rebooting, it would no longer boot. So, I re-wrote the image to this SD Card. After re-writing the SD card, when the board powers up it just gives me a GRUB command line.

I have the GPIO jumper moved to the outter pins so I can use the GPIO header on all the boards. I have pins 6, 8, and 10 hooked up to a sound isolation board called “EASY DIGI”.

I have many of these sound isolation boards, they work fine with my older AML-S905X-CC boards and the Raspberry Pi3 fine, I’ve not had any issues like I’ve described here in the past. I also have cm108 based USB sound cards connected to the boards, and the provided USB wifi as well.

I’ve not powered up or used the other three boards yet, trying to figure out what’s going on here. I’m proficient with Linux but this is a bit beyond me. Any help would be appreciated.

Update, with the 2nd new board, I swapped out the SD card for another of the new 256GB cards (3rd new SD card I’ve tried). All was going well, installing packages and such. Then in the middle of compiling direwolf, I got input/output errors. Capturing what it looks like this time.

This output picks up towards the end of building/installing direwolf:

-- Installing: /usr/local/share/doc/direwolf/WA8LMF-TNC-Test-CD-Results.pdf
-- Installing: /usr/local/share/doc/direwolf/Why-is-9600-only-twice-as-fast-as-1200.pdf
-- Installing: /usr/local/share/man/man1/aclients.1
-- Installing: /usr/local/share/man/man1/atest.1
-- Installing: /usr/local/share/man/man1/decode_aprs.1
-- Installing: /usr/local/share/man/man1/direwolf.1
-- Installing: /usr/local/share/man/man1/gen_packets.1
-- Installing: /usr/local/share/man/man1/kissutil.1
-- Installing: /usr/local/share/man/man1/ll2utm.1
-- Installing: /usr/local/share/man/man1/log2gpx.1
-- Installing: /usr/local/share/man/man1/text2tt.1
-- Installing: /usr/local/share/man/man1/tt2text.1
-- Installing: /usr/local/share/man/man1/utm2ll.1
Scanning dependencies of target install-conf
Built target install-conf
Created symlink /etc/systemd/system/multi-user.target.wants/direwolf.service → /etc/systemd/system/direwolf.service.
root@libre-computer-board-2:~/pi_radio# systemctl status direwolf
-bash: /usr/bin/systemctl: Input/output error
root@libre-computer-board-2:~/pi_radio# pwd
root@libre-computer-board-2:~/pi_radio# ls
-bash: /usr/bin/ls: Input/output error
root@libre-computer-board-2:~/pi_radio# reboot
-bash: reboot: command not found
root@libre-computer-board-2:~/pi_radio# lsblk
-bash: lsblk: command not found
root@libre-computer-board-2:~/pi_radio# df -h
-bash: /usr/bin/df: Input/output error

Another update,

I’ve found one of the older (and brand new) SanDisk 32GB SD cards in a drawer. I have written the same image onto it. This card is working perfectly. OS updated, all packages installed, everything is working as expected.

So that leaves me thinking what’s wrong with these newer faster bigger SD cards… I have two suspicions.

  1. I bought 5 bad SD cards? Maybe a bad batch from SanDisk ???
  2. Libre Computer Board isn’t able to handle the speed these newer cards offer?

Other suspicions? Thoughts? Any help and/or direction would be greatly appreciated.

Another update, the 1st new board that I thought was OK is now having input/output errors again… I’m just about certain this is something to do with these new 256GB SD cards…

This is the listing description for the cards that are having problems:

SanDisk 256GB Extreme Pro Micro SD MicroSDXC UHS-I U3 A2 Memory Card W/ Adapter

Hi, I’ve only tried sizes up to 64 GB, But I have had good luck with all the Sandisk products I’ve used, including the ImageMate Pro, which seems to more-or-less match the specs you listed.

Amazon sellers and the like often sell counterfeit electronics. Are you sure the new sd cards are legit? I’ve taken to buying storage media from a big-box retailer for this reason (And everything else I can get in-person right now because of the strike).

After you update the system, try using libretech-flash-tool and installing the latest firmware on the card to see if it fixes it. The firmware improves compatibility with some MicroSD cards.

sudo ./lft.sh bl-flash aml-s905x-cc mmcblk1 force

@librecomputer I tried as you’ve suggested. It wasn’t able to get through the OS upgrades this time, hit the issue mid-upgrade. I was able to power cycle, and fix the incomplete installs. Then I ran the command you provided in that cloned repo and rebooted. Later when installing more packages, it had another input/output error.

I assume there’s a reason you said to update the firmware after OS upgrades. I’m going to give this another try, but I’m going to run the command before the OS upgrades as well as afterwards.

Where did you buy the MicroSD cards? Do you have a link? There’s a lot of fake online. If you paid less than $20 for the 256GB Extreme Pro model, it’s most likely a fake.

We have about two dozen SanDisk models in our labs and have not had any issues.

Ebay. I’m looking at my purchase history and clicking on the item, it’s no longer listed on Ebay. When I click the user that I bought it from, it says they are no longer a registered user.

:man_facepalming: I’m regretting it already. I’m going to try to get a refund.

Never buy MicroSD cards off eBay. It’s basically all fake unless the seller has thousands of sales and a good rating.

1 Like