HDMI glitching out freezes system

I have a Le Potato am-s905x-cc that seems to freeze when the HDMI/display glitches out? Tried two different displays with two different HDMI cables. (see attached image)

The board can boot fine it’s just that every time the screen glitches the whole system freezes.

Is there any way to fix this issue or could I use the device headless with ssh and disable the HDMI port?

Can you let us know the make and models of the displays you have tried where it freezes? Are you on the 1GB or 2GB board?

It’s a 2GB board and the two monitors are a Samsung LC24F392FH and a Monoprice 32C1R

They look like standard 1080P and 4K displays. You shouldn’t have any issues. What is the filename of the image are you using?

currently have the debian-12-gnome-arm64+aml-s905x-cc.img on the sd card but have also tried the debian-11-base-arm64+aml-s905x-cc.img with the same result

Have you tried a different power supply? It’s best to have an UART dump of the system when it freezes. Without UART logs, its hard to know what is causing the exactly issue unless the system is able to write the error out to disk before crashing.

Heres a video:

Note it seems to happen pretty randomly, sometimes right before grub even loads other times when it’s trying to load Debian, or just sitting around and doing nothing when Debian is loaded.

How are you powering the board?

In the video, it uses a Samsung Adaptive Fast charger with the specs of 5V and 2A.

Also tried the Wall wart that comes with an echo dot which is 5V at 2.4A with the same result

The random pattern means memory corruption. Given that you said the pattern occurs randomly during u-boot, Linux, or sitting at Debian desktop, this is either due to power issue or a bad board.

There’s several things you can try to narrow it down.

  1. Check your board for any missing components or bad soldering.
  2. Stop u-boot and run the built-in memory tester memtest.
  3. Flash our Raspbian via the Raspberry Pi Imager and set ssh and username and password. Then boot the board without HDMI plugged in to see if the board still crashes.

How would I run the built-in memory tester memtest

Keep pressing escape at startup and then at the prompt type memtest.