Help with GPIO (UART) and Klipper (Skr mini e3v3 and ALL-H5-CC)

Hello everyone,
Noobie here, I’ve managed to install klipper on an SKR Mini E3 V3. I have the correct communication pins flashed…

If the screenshot above doesn’t link, here are my settings for my klipper flasher:

[*] Enable extra low-level configuration options
Micro-controller Architecture (STMicroelectronics STM32) —>
Processor model (STM32G0B1) —>
Bootloader offset (8KiB bootloader) —>
Clock Reference (8 MHz crystal) —>
Communication interface (Serial (on USART2 PA3/PA2)
(115200) Baud rate for serial port
() GPIO pins to set at micro-controller startup (NEW)

I’ve flashed back and forth between Marlin firmware and Klipper firmware, just to verify I am flashing the board properly, and I am. I have four of these printers, and I have been using them via old laptop / ubuntu installer. I needed to downsize and clean up my setup, hence, enter the libre board.

On the SKR, I’m using the TFT connection on the board, aka TX2,Rx2.
These pins cross with the Tx and RX of my Libre Computer model ALL-H5-CC.

I am using the Raspi distro, per Libre website download and instructions. I have used raspi-config to turn on UART, I have also enabled the overlay UART1 and I am utilizing the pins 8 and 10 on the board.

I have even tried to duplicate the Libre board SD card and have two (Libre) boards communicate with each other over each others’ 8 and 10 pins. I have also reversed the pins and tested both possible positions of Rx and Tx. No matter what I do I can’t seem to get the communication pins to see any devices connected.

There are no results for ls /dev/ttyA*, I have /dev/ttyS0,s1,s2,s3. I’ve tried doing through the dmesg and I do not see any devices here either. I have followed every Klipper and Raspberry Pi GPIO tutorial out there, and I cannot find my solution.

Please help, I clearly have no idea what I’m doing. I have read thru the overlay stuff for Libre boards, but I only need the one overlay UART1 if I’m not mistaken since I’m only using two pins.

PS - The Libre board will communicate with my SKR board via USB when I flash the (SKR) board for USB communication. So I know I’m close and on the right track, but I’m trying to reduce the amount of USB cables I’m using and have a cleaner setup.

This is not how to turn on UART for our boards. Please use the proper method for our boards: ALL-H3-CC H3/H5 (Tritium) Overview Resources and Guides

uart1 is enabled correctly

On Tritium:

UART1 is ttyS1
UART2 is ttyS2

ttyAMLX is for Amlogic boards like Le Potato

So, although ive enabled both, I’m only using pins 8 and 10 as shown in my pic above, after configuring my SKR printer.cfg file to match your comment above…
I know you cannot troubleshoot my other board, but I still don’t think I have it setup properly, and I just dont understand what steps im missing.

I do have another board running just fine as i stated above, but only via usb. I have some buck converters to remove the power usb, now i just want them to communicate via the tx and rx pins so i can eliminate the other usb cord.

So what is the issue? Once you enable it, UART1 and UART2 becomes configured as UARTs on boot.

The board is still not communicating via pins 8 and 10. Something is still not setup properly.

Open a minicom session on /dev/ttyS1 and check on a oscilloscope? It’s most likely whatever software you’re using is not communicating with /dev/ttyS1.

I thank you for all your back and forth input, telling me that the ttyS1 = uart1, ttyS2 = uart2 was the key i needed. So I do not have an oscilliscope, however i was able to get the board to talk via pins 11 (uart2_rx) and 13 (uart2_tx).
I was not able to get uart1 to work for me even tho its enabled. I’m satisfied that uart2 is working, I’ve been trying to figure out this puzzle for days.

Thanks again.

1 Like