Helps create the image of the s.o

Hello… I would like some help… I have a sweet potato plate. and downloaded win32diskimager and ubuntu. but when I click on write it takes almost an hour but says the micro SD is ok.
I’m using Windows and the micro SD has the exfat partition and no files inside.
this is normal? I already went to fdisk and cleaned the SD partition, but after running the disk imager it goes back to exfat and without any files… what am I doing wrong? What partition does the SD have to be on?
Could someone help me?

We don’t use exfat in our images so you definitely did not flash the right device.

Hi… I don’t think I know how to work properly with this win32disk. but I managed to create the micro SD using the Raspberry Pi imager and it worked fine my friend. I’m using a Lenovo memory card bought on Aliexpress… and everything worked fine…
friend… another question is it possible for me to insert a micro SD card without an operating system and boot from the pendrive with Ubuntu to install it from scratch?

Yes, you can use the libretech-flash-tool to flash just the bootloader and then boot from whatever media you would like.

Hi friend… I found this bootloader on github but I don’t know how it works. What do I do with this code?
Do I run it all on Linux, which is on Sweet Potato?
Can you teach me step by step how to make this flsh tools? thanks

git clone GitHub - libre-computer-project/libretech-flash-tool
cd libretech-flash-tool

./ board-list

./ dev-list

sudo ./ bl-flash aml-s905x-cc sdb
BOOTLOADER_get: downloading aml-s905x-cc bootloader to /tmp/tmp.otrZBzPL4o.

–2022-09-02 23:48:50--
Resolving (…, 2600:3c00::f03c:93ff:fea1:358c
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 851968 (832K) [application/octet-stream]
Saving to: ‘/tmp/tmp.otrZBzPL4o’

/tmp/tmp.otrZBzPL4o 100%[================================================ ==============>] 832.00K 3.45MB/s in 0.2s

2022-09-02 23:48:50 (3.45 MB/s) - ‘/tmp/tmp.otrZBzPL4o’ saved [851968/851968]

BOOTLOADER_get: downloaded aml-s905x-cc bootloader to /tmp/tmp.otrZBzPL4o.
BOOTLOADER_flash: dd if=/tmp/tmp.otrZBzPL4o of=/dev/sdb oflag=sync bs=512 seek=1 status=progress
BOOTLOADER_flash: run the above command to flash the target device?
dd if=/tmp/tmp.otrZBzPL4o of=/dev/sdb oflag=sync bs=512 seek=1 status=progress
815616 bytes (816 kB, 796 KiB) copied, 2 s, 407 kB/s
1664+0 records in
1664+0 records out
851968 bytes (852 kB, 832 KiB) copied, 2.09354 s, 407 kB/s
BOOTLOADER_flash: bootloader written to sdb successfully.

friend… to boot a pendrive, I need to have the eMMC module, right? This module would simulate booting from the pen drive.


Can I use this adapter to make these flash tools? Thank you friend!

No, that is not compatible.