How to Update grub

I’ve asked this question elsewhere so although it’s technically a repeat request, I’m unsure how to get a solution without asking again.

Raspberry Pi OS does not have grub so Pi specific searches return nothing useful. Commands sudo update-grub or/and update-grub2 return command not found. The command sudo grub-mkconfig -o /boot/grub/grub.cfg also returns a command not found response.

Can someone chip in with any ideas about how I might manually update grub on the Libre issued Bullseye for Renegagde?

Thanks in advance

This thread I started from a while back I believe will give you some guidance:

About midway through the thread is the discussion of manually running grub updates.


Thanks, I really appreciate your input but I still get command not found response.

I’m not sure what this indicates and no idea if it’s safe to install a grub alternative or if that’ll enable a kernel update to load.

I guess if I’m the only one with this issue it’s something peculiar to my setup or the way I’m doing things.

Is your PATH set wrong somehow? I am running Bullseye on a Renegade and both update-grub and grub-mkconfig are right in /usr/sbin just like they are on my production Ubuntu x86_64 systems.

Looking in /usr/sbin there’s no update-grub or grub-mkconfig, nothing for grub at all actually

Interesting. On my Renegades a “dpkg -l | grep grub” shows the following packages installed:

grub-common, grub-efi-arm64, grub-efi-arm64-bin, grub-efi-arm64-signed and grub2-common

Maybe a package or two didn’t get installed for some reason? Not sure.

I have only three, grub-efi-arm64-signed and grub-efi-arm64-bin are missing

Can I install these manually? Sorry for all the questions I’ll see if I can find it somewhere

Installed grub-efi-arm64-signed but grub-efi-arm64-bin has unmet dependencies.

I think this is well outside the time I have for fixing this to achieve a solution.

Thanks for your time Bill

Again, do not create new threads for the same issue.

You do not have a standard image. All of our images use GRUB. If the GRUB packages were not installed, you are either not using our images or uninstalled GRUB.

There is documentation for GRUB all over the internet. Our images use the standard Linux process for booting. We do not do non-standard things.

Ok, you need to take this as a matter of faith - I did not uninstall grub and I am using the PiOS image from your respository.

As I’ve already stated update-grub returns command not found therefore you can assume (I think it’s safe to say) that whatever solutions there are across ‘the internet’ will return the same response.

If you’re not in a position to support your hardware given these factors then that’s fine but it’s just the most half-assed incompetence to just assume that a customer is lying about their setup as you appear to have done here.

There are two aspects that may be considered ‘non-standard’ about my image. One is that I am using the 32bit cli Buster image (from the Libre repository) that has been upgraded to Bullseye as I was unable to solve a login problem I had with your Bullseye image, it is therefore a 32bit Bullseye install. The second aspect is that I have installed OMV over this clean image. Whether OMV has removed grub as part of the install script I’m in no position to say. It seems unlikely to me but then it’s pretty clear I’m not equipped to judge any of this with any kind of substantive clarity.

Have you tried replicating this setup on a fresh SD? I know its time consuming, but you could check on grub after each step. At least you’ll know if something you’re doing is removing GRUB.

If you back up your current setup, then theres no harm in trying to copy over the missing files from the new image too. Who knows, it might work.

I certainly belive something like this could happen accidentally. I somehow deleted the contents thermal_zone0 once, with nothing but the echo command. I definitely didn’t explicitly tell the computer to do that.

Thanks. I’ve done a fair amount of playing around but transferred to an eMMC for this install from a clean setup so unlikely anything bar the OMV script could’ve uninstalled it.

I don’t mind experimenting so much except the mass storage mode on the Renegade is a drama and unfortunately it’s a different kind of drama (though somewhat more managable) to switch from eMMC to SD and the other way around. Libre eMMC modules are not made for constant removal and I’m not keen to push it more than I have to.

If it were possible to dual boot bw say an eMMC system and an SD system that would give me some flexibility but I asked about the possibility of doing that some weeks ago here with no response.