I can't get my board to work reliably, errors appear on the screen - ROC-RK3328-CC

I get errors with all of the OS’s I’ve tried. The OS images were downloaded from your official site, used the SD Card Installer tool to flash the card, some OS’s boot the first time but not after rebooting, some others just won’t load at all. I get errors in all of them, I’m thinking i got a board with bad RAM. Here’s what I see.

Can you try to re-download the images? We recently refreshed the images three days ago and brought a lot of updates to ROC-RK3328-CC.

I downloaded the base and desktop images just hours ago. They have a date of 2023-Jul-26. Server I got it 2 days ago but I’m pretty sure it’s the new image.

The bootloader date does not look correct. July 1st. Our released images should be December 2022 or July 2xth 2023.

I assume this is where I should take the boot-loader file from: Index of /ci/ which file is the right one though? Also, is this the right tool to flash it? SDDiskTool_v1.56

You shouldn’t have to flash the bootloader yourself. The images already include these bootloaders.

So do I wait for a new release then?

  1. Go download the latest images from the distro server.
  2. Flash them.

Don’t use boot.libre.computer unless you know what you are doing. The previous screenshot was not the latest image. It’s based on a build version that’s not released.

I did download the latest images from Index of /ci/ubuntu/22.04/ I’m having issues with all of them

What is the problem?

The first screenshot you shared had a date of 07/01/2023.

Yes, and I downloaded several images last night as you can see in my last screenshot, they all crash.

It says something about “bad page state” (first screenshot), that happened while I was running apt, and that “modules linked in” with a long description sometimes appears while I’m booting up the board for the first time with a fresh image. The system hangs every time.

Give us a bit, we will try to replicate.

There’s two possibilities:

  1. Bad board.
  2. Bad power supply.

Where and when did you purchase the board?
What are you using to power the device?

From Amazon, ordered it last Sunday.

I’m using a USB charging port from my UPS (5V 3A).

Amazon should offer free replacements. Just order another one and see if the same problem occurs. If it does, it’s most likely the cable. Make sure it’s of sufficient thickness.

Thanks, I’ll try different power supplies and cables first. I’m hoping it’s not the board.

it seems like the board is the problem, thanks for your help.

1 Like

We have replicated the issue on our end. It seems like a software bug that only affects 4GB boards. We’re looking into it.

We set the DDR4 voltage too low for the increased frequency vs the previous release. On the 4GB boards, there is more voltage drop due to greater load current from more DDR4 chips. This resulted in the memory dipping to 1.1V and causing consistency errors. Please use libretech-flash-tool to fix the bootloader.

sudo ./lft.sh bl-flash roc-rk3328-cc sda

Replace sda with your block device name for the SD card. New images are being uploaded to the distro server.

I tried again with images from nightly yesterday.
Raspbian now does not freeze during the boot messages but then my monitor just goes to sleep forever.
Ubuntu image runs and installs without freezing finally!