IR receiver help - Raspbian and CoreElec

Hello! I have a brand new Le Potato and I’ve loaded Raspbian on it from the Libre site.
I want to use a remote control for videos. I’ve installed evtest and when I use a remote (I’ve tried several) nothing happens. If I use evtest and choose the keyboard, I can see a bunch of stuff when I press a key.
So I assume my IR is not working, right? evtest should display “stuff” when I press the remote buttons, right?

I also have a CoreElec running on another SD card (i use this because it’s the best at playing movies from an external HDD). I’ve tried to configure the TV remote, but again it does not seem to register when I press the buttons.

Thank you in advance for your help!

  1. Make sure your remote is an IR remote. There should be an LED in front. There are a lot of bluetooth remotes so they obviously will not work. Some remotes have IR for certain buttons and RF for other buttons.
  2. Make sure there’s nothing in front of the IR sensor that would block infrared light.

I am using a standard universal remote. I have also tried several other remotes to my TVs, stereo, etc. etc.
Obviously there is nothing in the way :slight_smile: , I would make sure of that. I am pointing the remotes directly at the IR sensor.
So I am assuming the IR receiver on the board is not functioning correctly then.
Thank you for the quick reply.

The IR sensor is a tested path during manufacturing. An unit does not pass QA without it working. Try getting another board. If it works, it is the board. If not, it is the software or remote.

Make sure that the decoder protocol is setup correctly for the /sys/class/rcX/protocols. If the protocol is not setup, evtest will not show anything.

You can run sudo mode2 -d /dev/lirc0 to check the IR sensor itself.

Hello. I’ll try that!
(Sorry for the delayed response. I appreciate the input)