Latest Raspbian on Le Potato stuck at 1.5GHz CPU speed?

I’ve got a fresh install of 2022-09-22-raspbian-bullseye-arm64-lite+aml-s905x-cc and then run sudo apt update; sudo apt full-upgrade. I can’t seem to get the CPU clock to vary? It is stuck at 1.5GHz (with some very brief dips to 1.2GHz). This is running nothing, load of 0.03.

$sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
$sudo cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq

I’ve tried it both with HDMI and headless, in case it was the monitor resolution causing the clock speed, but they both give the same result. Am I reading the CPU clock speed wrong, or is there a bug?

I also noticed there are no conservative or powersave governors available, which would be better for my use case (battery powered).

Thank you

I think my mistake was that just executing that simple cat command was enough for ondemand to max out the CPU clock speed?

I’ve now installed cpufrequtils and I’m getting the spread of clock speeds I’d expect for a board with very low load. eg.,

cpufreq stats: 100.0 MHz:89.51%, 250 MHz:5.11%, 500 MHz:1.18%, 667 MHz:0.54%, 
  1000 MHz:0.80%, 1.20 GHz:0.47%, 1.51 GHz:2.38%

I can also now see the conservative and powersave governors. With conservative set the CPU is now only 100MHz or 250MHz when executing the same simple command.

If you do a strace on cat, you will realize it does a ton of things that will cost any sensitive CPU governor to go to full speed.