Le Potato images are all garbage

Legit. every distro and every image i’ve downloaded for the the Potato is straight trash. nothing boots right. boot loops upon boot loops. if you’re going to market a sbc to compete with RPi, at least have your shit together.

I’ve tested quite a few; they have all booted first try except Lakka, which took a search on this forum, and a single file swap, about 10 minutes. We’re all using these images.

I think you’re doing something wrong. Boot loops are usually an out of spec power supply or images weren’t extracted before flashing.

Oh yeah, and welcome to the community or whatever.


You are entitled to your opinion but the problem is your power supply.


I’ve tried multiple different power supplies, all capable of providing more than enough current (ie. they work powering a RPi 3b+).

I’ve tried multiple brand new SD cards.

When it’s trying to boot, the text on the screen is garbled and unreadable. (Tested on multiple monitors and TV’s)

I can get it to boot if I don’t plug the USB keyboard in (tried multiple keyboards), but what good is it if I can’t use the keyboard to set anything up?

I also apologize for my harsh and hasty initial post. I’ve been searching google and smacking my head off the desk for 3 days just trying to get something to boot and run correct.

  1. If it can power a Pi 3, it can definitely power a Le Potato. Make sure the power supply is between 5V and 5.5V. Some Pi 3 Power supplies deliver between 5.5V and 6V which is out of spec and will fry USB devices.

  2. Can you send a picture of what you see on your monitors? Along with the monitor make(s) and model(s) so we can look up the resolution?

  3. Keyboards should work fine. If it does not, it is usually because of a power problem. A picture of your setup would help.

If you are having problems with the stock images, maybe you can try some others,

Official Libre Computer Support Group | Facebook can get more help here.



(Choose s905x for Le Potato)
aml-s905x-cc - Google Drive Android 9 Le Potato

and there are plenty of youtube videos about Le Potato. I will locate a few and post them here.

Actually, my main goal was trying to build a RetroPie setup on top of Ubuntu, Debian, or Armbian as I absolutely despise Lakka.

I finally got things with RetroPie somewhat working with the Armbian image since it actually ended up booting correctly with none of the errors I previously mention.

I’ve since found a Batocera image that works beautifully no matter what is plugged into the USB ports or what monitor I have it attached to. batocera.linux - 2023/03/04 23:03:56 (o2switch.fr)

Thanks to all for the suggestions and again, I apologize for my kind of angry OP.


Ah. You recanted. I was going to flame you because Armbian imstantly worked for me. Only weirdness I had was having to use --fix missing for the first time ever, because there wasmsome kind of desync with apt-get. After that everything has worked perfectly. The le potato is ALOT less catty about power supplies than my rpis or tinkerboard.

There is no point to flame any other users here. Yes, there are a lot of people who get the basics wrong. This is for helping people, not social media.