Le-potato scramble network when shutsdown

My le-potato is working well when it is on or when I reboot it. However, when I shut it down, a get the yellow led on the ETH connector flashing fast and none of the other devices on the network have connection. Taking the ETH cable off from the connector makes my other devices connected again, but if I plug it back they stop working again.
The only way to make it work again is removing the power from the board.
I’m running Radpbian latest version downloaded from libre website and did the procedure to update the firmware.
Don’t know what else to do to troubleshoot this as I already changed the switch too.
Please advice.

librecomputer said that switching off and back on again is the only way to restart.

What is the make and model of your network device? Is it a switch or a hub? Upon shutdown, Le Potato goes into WOL mode which is 10M. If the network device is a hub and not a switch, this would cause issues.

My switch is a HP 1410-8G, but I tested it too in my TP-link router and got the same results.

Is there a way to disable the WOL? I don’t need it.

We have not had anyone else report this issue yet. A switch should not stop functioning because one device has an issue. If the network goes down because of a connected device, it’s a switch level issue. Are you able to run wireshark to do a network packet capture on another computer to see what is going on?

Hooked up a dell computer running windows 10 ( and wireshark got the packages on the attached pictures when the network goes down. A MAC-ctrl control protocol keep showing up, when I disconnect the cable it goes away.

My router is on

I really don’t need this WOL option, can you tell me how to disable it?

can you try this patch (if you are able to build the kernel)? which should disable the phy’s WOL feature


I’m sorry, but I’m not sure how to recompile the kernel. Found some tutorials on the internet, but nothing specific to Raspbian. Do you have any instructions to follow on this case?
Also, if I plug an USB Ethernet cable it will behave the same?
Thank you for the help

Update: I will try follow this and test your patch


Solved the problem by using an USB to Ethernet adapter and disabeling the onboard adapter. The USB interface doesn’t have the WOL option and it is gigabit, so in the end it will be faster and I’ve solved the problem I was having.

Thank you for the support.