Libre Computer AML-S905X-CC EMMC boot


Recently I’ve purchased [Libre Computer AML-S905X-CC ], and 32gb libre computer emmc drive.
I wrote the latest libre Raspbian to sdcard, copied Raspbian, Ubuntu and Debian 12 images for my device to sdcard and booted it. Then I login to os running on sdcard and used dd command to flush the emmc.
I’ve tried all tree images . Flush was successful, no errors, but now I’m not able to boot from emmc with none of mentioned images.
Emmc is mounted correctly and I can see it from os booted from sdcard, but boot from emmc is not working. It freeze, not even open display and red and blue lights are on, just as with booting from sdcard, but the screen is not opening and the the os is not booting.

Please advise what to do.

What is the exact command you used?


Here are the exact commands that I’ve executed.

dd if=2023-05-03-raspbian-bullseye-arm64-lite+aml-s905x-cc.img of=/dev/mmcblk0 status=progress
dd if=/dev/zero of=/dev/mmcblk0 ms=1M count=128

dd if=debian-12-base-arm64+aml-s905x-cc.img of=/dev/mmcblk0 status=progress
dd if=/dev/zero of=/dev/mmcblk0 bs=1M count=128

dd if=ubuntu-22.04.2-preinstalled-base-arm64+aml-s905x-cc.img of=/dev/mmcblk0 bs=1M status=progress
dd if=/dev/zero of=/dev/mmcblk0 bs=1M count=256 status=progress

I did this from the inside of 2023-05-03-raspbian-bullseye-arm64 installed on sdcard.

I’ve also tried without bs=1M, results were the same .


dd if=2023-05-03-raspbian-bullseye-arm64-lite+aml-s905x-cc.img of=/dev/mmcblk0 status=progress

Missed bs=1M.

dd if=/dev/zero of=/dev/mmcblk0 bs=1M count=128

You know that you’re wiping the image with this command right? If you ran this after the previous command, you are wiping off the first 128MB of the image that you just wrote.

Please read and and follow the instructions carefully.

I run the wipe after rebooting.
So the sequence was.

  1. dd write image .
  2. Reboot.
    2.1 Reboot fails
    2.2 Remove emmc
    2.3 Boot to os in sdcard.
  3. Wipe the disk .
  4. Try another image.

After writing the image I immediately do reboot and try to boot from emmc.
When it fails u wipe out the disk and try another image.

You missed the bs=1M. Without it, flashing will not work.

Also, please provide the full output of the commands.

Did you extract the images?

First I’ve cleabed out the emmc card :
dd if=/dev/zero of=/dev/mmcblk0 count=128 status=progress
128+0 records in
128+0 records out
65536 bytes (66 kB, 64 KiB) copied, 0.00890138 s, 7.4 MB/s

dd if=/dev/zero of=/dev/mmcblk0 bs=1M count=128 status=progress
128+0 records in
128+0 records out
134217728 bytes (134 MB, 128 MiB) copied, 2.39457 s, 56.1 MB/s


dd if=debian-12-base-arm64+aml-s905x-cc.img bs=1M of=/dev/mmcblk0 status=progress
1865416704 bytes (1.9 GB, 1.7 GiB) copied, 24 s, 77.6 MB/s
1792+0 records in
1792+0 records out
1879048192 bytes (1.9 GB, 1.8 GiB) copied, 28.96 s, 64.9 MB/s


The same , OS is not booting .

Yes of course I’ve extracted image using xz utility.

A picture of your board and eMMC module?

When you boot with the eMMC attached, does it boot off the MicroSD card?

I’ve tried to boot via emmc with both attached and removed sdcard. The result is the same: it is not booting and not even opening the screen.

I’m new user so cant upload more than one image , so please download images from my server.

Everything looks right with the picture.

Copy and paste the full dmesg log after you run the dd command.

There was only one line in dmesg after flushing the image .

[ 179.838331] rc rc1: two consecutive events of type space

[ 13.585079] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 179.838331] rc rc1: two consecutive events of type space

Just in case s previous line as well.

Copy and paste the full log into a pastebin and post the link.

Here is the fill dmesg log after running dd

You have a damaged pin on your eMMC module. Take a picture of both the board connector and the module connector. Your previous image of the module connector is not very clear.

[ 3.412348] mmc0: switch to bus width 8 failed

Please see attached. As for me it looks good.

Just in case a close picture of rear side of device.