My le potato has a problem i don't know how to fix

My le potato refuses to connect to the internet. when I run any apt-get command it says: temporary error resolving “”. I have the ethernet cable plugged in, the power connected, and the keyboard connected. I have no clue why it will not connect. please help!

Which image are you using? What is the other end of the ethernet plugged into? With Ubuntu Server 22.04 it just worked sharing the connection off my desktop.

the image provided at " " it has the error!

The ethernet cable goes directly into the router.

There are an awful lot of distros listed on that page; I got it narrowed down to Ubuntu, so which Ubuntu image? Base, Server, or Desktop? What is the filename of the Image you flashed? I need to know if I’m going to try to replicate.

Hmm… I’m using that image, and had no problems with wired connection. Do the green and yellow LEDs on the ethernet come on? Have you tested this connection with other hardware?

I’ll flash a new SD to check again with the unmodified image, but I probably wont get to it until morning.

This looks like a networking issue and not an image issue. You are also getting the error “Temporary failure resolving ‘’” I would try some simple network diagnostics like pinging your router’s IP address and if that works then try using DNS names with a ping. You may not be getting an IP from your DHCP server on your router also, I have seen this issue in the past. If you can look at your interface status and it has an IPv4 address starting with 169.254 then you aren’t getting an address assignment.

It fails to ping the router.


I still need help with my problem and I still cannot fix it.

Yup, it is just networking not being up. Try the command “ip addr show” and post what that shows if it works. I’m pretty sure the ip command is present in just a vanilla install of your os image.

I still cannot get it to work!

If this is a networking problem, I’m probably not going to be much help. That is not my forte. I’ll give it a try, but this is my only day off for the next couple weeks, and frankly, I have stuff to do, so I can’t give it my full attention just now.

As I said, I used the exact same image, and did not encounter this issue. The best advice I can offer at the moment is to test the connection with another piece of hardware. Check and see if both LEDs on the ethernet port are on. I don’t want to teach myself how to configure a network through the terminal to find out you have a bad cable, or a bad port on your router.

You may want to log into your router and check the settings there as well.
You can also Google “Configure wired network ubuntu server 22.04” or similar; that’s how I’m going to try to help you when I get around to it.

I would be patient, there aren’t a ton of people on this forum answering questions, and we all have lives and jobs too. Sorry I couldn’t be more immediately helpful.

Again, I’m probably not the best person to answer this, so anyone feel free to correct me. It looks like you don’t have an IPv4 address.

There’s instructions here that might help you set it up. See “Ip Addressing”:

1 Like

angus is indeed correct. The output from the “ip” command shows that both your ethernet and wireless interfaces are up and completely unconfigured. “BROADCAST,MULTICAST,UP,LOWER_UP” indicates that the ethernet port appears to have link, but either you didn’t configure the system to use DHCP, your DHCP server isn’t working (unlikely if your other devices can get online) or your system has a blank static IP address configuration. I believe your problem, based solely on your questions, is that you chose a server image and not a desktop image. The server image assumes that you have experience with a server environment whereas the desktop image is just that, a standard desktop version of the OS that autoconfigures the ethernet and wireless for you. Your best bet is to indeed look for guides on setting up the network using Google, etc. like angus recommended, You are going to need to get familiar with either netplan, NetworkManager or dhcpcd to get things working on the server distro.

One final thought, and this may sound silly, you have rebooted the system after the OS was installed, correct? I have seen rare occasions where the dhcpcd doesn’t always start right on the first boot after installing but a reboot after that settles things down and it works. First time booting always has the possibilities of things needed to get settled in and processes taking a longer amount of time to startup.

1 Like

I just rebooted and it is fixed now thanks!

There seems to be a problem with the latest kernel. This happened to me too after doing apt upgrade and getting the latest kernel. I was only able to fix it by rebooting and selecting the previous kernel to boot into.

edit: looks like they have already posted a solution: Le Potato eth port stopped working - #6 by librecomputer