I have created a kiosk style dashboard using the potato for work and it has worked flawlessly for the past 2 months. Suddenly, a few days ago, the network connection stopped working. I troubleshot the problem and decided to start from scratch and reinstall everything which didn’t take too long. I tested it in my office and it worked as intended so I brought it back to the location needed and it didn’t work. Seeing that, I assumed it had to be a network issue and checked the port it was on on the switch and the port worked with another device. After that I had the assumption that it must be the wire, although this was a fresh cable I installed 2 months ago, but I tested the wire and it worked too.

Out in location there is a yellow connection light on the ethernet port of the potato but no green activity light. Today I came back in the office and grabbed the connectionless potato and brought it back to my office. When I powered it up it showed the orange and the green would flicker once every 10 seconds or so and in the GUI it would show internet coming in for a second then going out. Then, after waiting 10 minutes, the connection fully started working again. I really have no clue now what the problem can be, please help.


  1. Kiosk randomly stopped having network connection

  2. Fresh install seemed to fix the problem in my office

  3. Once back out in location it stopped again instantly

  4. Checked ethernet cable + switch port and both work with other devices

  5. Back in office with no changes, ethernet was spotty then began working entirely

If not the cable or switch, what could possibly be causing this problem? Especially after no change and it was working previously for 2 months.

Don’t use caps lock for thread titles. It causes your post to be flagged for manual approval since the system will increase the metric on the spam filter for your post.

  1. What OS are you running?
  2. What does the sudo dmesg log say when connectivity changes?
  3. What is the output of sudo ethtool eth0?
  4. What switch are you connected to? Brand and model.
  5. Orange LED is the data indictor. It will flash when data is being send/received.
1 Like
  1. Raspbian
  2. Currently I am running it in my office where the connect works fine and I’m not sure what you’re interested in for the long log it gives me. Would you like me to send a full log copy?
  3. Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Link partner advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Link partner advertised pause frame use: No
    Link partner advertised auto-negotiation: Yes
    Link partner advertised FEC modes: Not reported
    Speed: 100Mb/s
    Duplex: Full
    Auto-negotiation: on
    Port: Twisted Pair
    PHYAD: 8
    Transceiver: internal
    MDI-X: Unknown
    Supports Wake-on: ug
    Wake-on: d
    Current message level: 0x0000003f (63)
    drv probe link timer ifdown ifup
    Link detected: yes
  4. NETGEAR GS108
  5. Okay thank you.

Just bumping this for an update please.

  1. Yes, use pastebin and copy the link here. Please provide the log when the switch is not active. Screenshot with your phone will do too.
  2. There doesn’t look to be anything wrong with your gear. It’s Auto MDIX so cable doesn’t matter.

This is most likely a network setup issue.