No boot - red + blue lights only -- no green or keyboard or lan activity

My purpose here is to upgrade a Raspberry PI 2 project with a 64 bit OS. Right now I am trying to determine whether the potato board is DOA.

Hardware power, lan, mouse, keyboard and HDMI monitor work fine on the PI2. Transferring them to the potato fails due to no boot. I only see indication of power good red+blue led on solid - but no function at all. I have tried 5 different microSD cards verified i/o at 20MBs / 10MBs using the disks utility on Ubuntu linux. They are HC rated and work with a fussy Samsung video camera. All allow the PI2 to boot and run. I’ve tried the Raspbian OS and have downloaded and flashed Le Potato – Armbian desktop and cli oses. At this point I would hope the potato would say hello or complain but not yet.

I have ordered new SD cards; LaView 64GB Micro SD Card 2 Pack, Micro SDXC UHS-I Memory Card – 95MB/s,633X,U3,C10, Full HD Video V30, A1, FAT32, High Speed Flash TF Card P500 for Computer with Adapter/Phone/Tablet/PC which supposedly meets the potato specifications. A last and final attempt.

Surely some sort of POST indication would be in order here.

I haven’t had this trouble myself, but it usually turns out to be an out of spec power suply, or flashing without extracting the images first.

I’d check a 5V pin with a multimeter it should be within 5-5.5V.

Thanks for the reply. The problem just got much weirder – the potato booted and is running Linux lepotato 6.1.11-meson #23.02.2 SMP. I didn’t fix anything, or do anything except swap SD cards. They say the definition of insanity is the process of doing the same thing over and over expecting different results. Maybe I scraped corrosion off a SD card or potato memory slot.

My final point still stands. POST diagnostics would really help. Beep codes? Micro-console without MMC? Hint, hint?!

Should I write up a report for the Engineering Journal of Irreproducible Results?

You need to run our Raspbian OS rather than Raspberry Pi’s Raspbian OS.

SD cards are fickle beasts. If it isn’t brand new, it could fail at any time in these SBCs. We don’t have SMART and a complex BIOS watching our drives, so they tend to just give up and give no reason why. Good think to try a different card. It has “revived” quite a few SBCs on my bench.

Fickle, that’s being kind. I found a utility f3 (f3probe) which runs on Ubuntu linux. It seems to do a reasonably good job of evaluating SD cards. I found that the deficient cards reported many problems such as 50% unavailable storage space. The utility is fairly quick and watching the process with glances is insightful.

The new hotshot SD cards I ordered report 100% capacity and uniform 10/10 MB/s. The older card that worked tested deficient but okay.