Raspbian 12 Bookworm and 11 Bullseye for Libre Computer Boards

I’m trying to change the screen orientation in Raspbian (it’s upside down). Google says to click on ‘Screen Configuration’ in preferences, but no such option exists. What am I missing?

New to SBCs and Linux, so I can enter commands into the terminal but don’t know much more than that.

never mind. ran command arandr which opened it.

The Distro download server for the individual downloads seems to be down. Clicking on any of the images results in:

computer-libre-distro.us-east-1.linodeobjects.com ’s server IP address could not be found.”

Akamai Linode has a DNS problem that they are working to resolve. https://status.linode.com/

Thanks for the update! I can confirm that they must have fixed the issue and I am able to reach the images now! :smiley:

How can I create a password for a user on a headless system when I do not have access to another Linux system?

The file can be modified in Windows. The first partition is readable and automatically mounted. You can create the file in the base folder of the drive in Windows.

I’m following these instructions using the Pi Imager in MacOS, setting username/password under advanced and adding an SSH file to the boot partition.

Renegade seems to boot fine, terminal reports incorrect password when trying to login. I’ve reinstalled 5 times same result.

Any ideas?

Did you check that the Pi imager created the right files?

What am I looking for?

I did notice that it seems like it’s supposed to generate an SSH file yet clearly it doesn’t so you may be correct that this is the problem.

I tried a manual config but MacOS terminal doesn’t support the openssl passwd –6 command.

userconf or userconf.txt file in the first partition. You can use an online generator.

I did look for an online generator.

I’ll look again, thanks for your time

No luck using https://sha512.online, still get “Permission denied (publickey,password)”

I’m thinking maybe I should try an older version of Raspbian…?

Same result on Buster as on Bullseye

I tried the both images for ROC-rk3399-PC via microsd card . The board boots successfully into the DE, but the USB devices are not recognized any more. I could use the USB keyboard in the Grub menu (move selection, edit entries etc.), but once the DE is shown the USB device is not recognized anymore. lspci and lsusb commands report nothing, the output is just empty. I tried different USB keyboard and its same. All USB ports behave the same. I changed the microsd cards as well and tried with different adapters as well. The behaviour is same with Ubuntu and Debian images as well. I am planning to use a USB HDD as storage and this issue is not allowing me to proceed further. Please provide some suggestions.

I’ve loaded 2022-09-22-raspbian-bullseye-arm64-lite+roc-rk3328-cc.img to a new 3328 board and it boots and runs fine. It always runs headless and the setup worked fine, ssh and the user account were set up and work.

I logged in to it and added some user files and then I added samba and configured it and that worked fine, I transferred some files via samba no problem.

I created an fstab entry to mount a usb drive and that all worked properly. I plugged in a Sandisk extreme pro 3.0 drive which takes quite a bit of power, the ammeter indicated below 500ma for the drive plus the 3328 and briefly it spiked at 1a.

I left the thumb drive in and rebooted and the samba installation had disappeared, my user files are still there but changes to them do not persist across reboots. If I touch a file named ‘it’ in /etc/ and reboot then the file is not there. Apparently I am in a kiosk mode or something but I’d like confirmation, or maybe it’s the sdcard.

The sdcard is new and HC, they’re very highly rated but this is the first time I’ve tried this brand. Could this situation be caused by the sdcard?

I was not able to find out what the difference is between the cc and pc OS image files, perhaps I just chose the wrong one. I do not want kiosk mode.


update: changed to state that my files are NOT preserved across reboots. Somehow I’ve done something to this file system that I’ve never seen before. I may just try rebuilding a new one.

Am I missing something? I can’t seem to figure out how to SSH into raspberry on Le Potato.

Your file is in the wrong location. It should be on the first partition which is FAT32.

Update: I built a new system on a sandisk ultra and it works perfectly. I’m chalking it up to a bad sdcard.

I’m very confused on how to enable SSH. I tried Raspberry imager with appropriate settings. No userconf.txt or ssh files were created so I added them manually. I saw the firstrun.sh, user and password were there but no new files. I added files to MicroSD first partition but still can’t ssh?

SOLVED: I had to run the command sudo rename-user So I could fix my Keyboard layout. For some reason it was set to UK and not US when I was setting it up. This messed up my SSH password.