Raspbian 12 Bookworm and 11 Bullseye for Libre Computer Boards

I’m in the same situation. How was this resolved?

Unable to login following headless instructions. Can install Buster and upgrade from there but would like afresh 64bit Bullseye.

SSH file and userconf installed, get “sorry try again”. I have reburned so may times with both Pi Imager and Etcher I’ve no idea what the problem is. Have no trouble with Buster, Armbian, Ubuntu…

Could be keyboard layout as SSH is working but layout settings in Pi Imager don’t seem to help.

Would try with Debian and Diet script from there but you’re not offering Debian images

Definitely using the first partition

Are you having a problem with userconf? This has been a tested path and it is most likely user error.

userconf seems likely except I’m creating with BareBonesEdit and have tried both with my own hashed username:password combo and the stock hashed pi:raspberry combo

This is a tested path meaning that it definitely works on the images. It is most likely your hashing for the password or the format of the file.

Thanks but while this makes sense (and was my conclusion too) I’ve tried as I said a standard hashing of the old stock user/password combo with the same result (connection refused).

Is there something obvious that might be easily missed with formatting?

I’ve looked at what others have done and mine looks no different, just an otherwise blank text file with username:hashedpassword saved as userconf

I know this is uber noob, if anyone else cares to kick in with a view I’d be glad of the input

Do not post the same issue across multiple threads. Please delete your other threads for the same issue.

Here’s what got me some major progress:
Loosely followed instructions here:
Downloaded this Debian image:
libre-computer-aml-s805x-ac-debian-stretch-headless-4.19.64%2B-2019-08-06.zip (found at this location: Index of /board/libre-computer-project/libre-computer-board/image/debian/ )
Unzipped with 7zip
Used Raspberry Pi Imager to write the image to usb thumb drive
La Frite now boots
It seems many of the images don’t work (I don’t know why)

1 Like

I’m trying to hide boot messages for kiosk use, and I’ve tried changing /etc/default/grub and /boot/cmdline.txt. Both didn’t work. Can I get some help on this?

Raspbian on Rk3328, I have flashed the sd card several times now and it seems that the raspberry configuration gui does not open for me although sudo raspi-config works fine.

Got this ROC-RK3328-CC from Amazon today. Usually, I’m pretty good with such things. For the life of me, I cannot get it to boot. It get solid red light and green heartbeat but does nothing after that. I have tried multiple power supplies up to 2 amp, multiple cables, written rasbian lite and the rasbian full image multiple times with balena and pi imager. Have set up networking info in both pi imager and manually edited the text files to add the info. I have plugged it into the network with a cat 6 cable. I have plugged it into several different computer monitors. They just go to sleep. It never shows up on my network. I even plugged in a usb wireless card…any ideals before I send it back to Amazon?

What monitor are you using?

I got the ROC-RK3328-CC board, using KOOTION 32GB microSD card. I’m new to programming, and I’m trying to write a script where during bootup the PI will navigate to a work-related website & login.

I’ve been using scripts like these: STICKY: How to use Autostart - Raspberry Pi OS (Desktop) - Raspberry Pi Forums & Setup a Raspberry Pi Kiosk with Chromium – O'Brien Labs. to try and accomplish the job. However after rebooting the changes wont take affect.

OS wise I’ve tried both 2022-09-22 raspbian-bullseye-arm64+rock-rk3328-cc.img & 2022-09-22 raspiab-bullseye-arm64-lite+roc-rk3328-cc.img.

Any help would be much appreciated. Thanks

We have a YouTube video highlighting the use of Wayland and Chromium. It’s especially useful for Kiosk mode with a good amount of acceleration. This is the recommended path and it is much faster than using Pi OS.

silly question - is there a 32bit Bullseye image for the 905X or any other platform?
Due to certain libraries I’m kinda stuck on 32bit for now; I’ve played with the older Buster image but run into other issue. Hence the question.


No, generating images for this target is prohibitively expensive in terms of testing and validation. You need to use GitHub - libre-computer-project/libretech-raspbian-portability

1 Like

Thanks for the quick reply. I’ll give this a try :+1:

I have the same issue with my AML-S905X-CC. When I try to open the Configuration GUI, I get an hourglass mouse cursor for a few seconds and then nothing. I tried running rc_gui from the command line and I get nothing from there either. raspi-config works.

So far everything else seems to be working fine.

rc_gui looks for a Raspberry Pi component (start_x.elf) that we have removed from the system. raspi-config is the recommended alternative.

1 Like