Raspbian Bookworm - VNC - Running Headless - Sweet Potato (& probably Le Potato)

After a frustrating couple of hours I’ve finally got Bookworm running headless and the solution was there all the time.

Basically ignore any advice about installing any additional VNC Servers (Tight, Tiger, Real, etc) or additional VNC Viewers.

Stick with the Wayland VNC option in raspi-config - advanced options. However do enable VNC in raspi-config - interface options. Just don’t expect any feedback in the Header bar to tell you the Wayland VNC server is running - I’ve been conditioned to look for RealVNC or X11vnc !!

Run sudo ss -ltnp to check that wayvnc is listening on port 5900.

Then just put the IP address of the Sweet Potato into your regular vnc viewer on your main computer - RealVNC viewer in my case and your up and running. You will probably get the square dot cursor instead of the arrow but not too much to complain about !

No need to use VNC for file sharing just install Samba.

I always set up Samba using these instructions :-

How to Setup a Raspberry Pi Samba Server - Pi My Life Up