Raspian Bullseye image boots fine from microsd but locks up using flashtool and usb ssd

Using the Libre Computer raspian bullseye lite image with my aml-s905x-cc and have some problems.

Using a microsd card the image boots completely and works fine. But, put the same image on a ssd using flashtool to boot the usb ssd, it gets part way through the boot process and stops at the following point:
[ 7.903915] systemd-journald [315]: received client request to flush runtime j

cannot open access to console, the root account is locked.
see sulogin(8) man for more details
press enter to contimue

The interesting thing is that the Libre Computer buster armhf raspian lite image boots and works just fine.
Is this a flashtool problem or ??

BTW, the usb ssd is running on a powered usb hub to stop any power problems.

Flash the image again. It was probably corrupted previously because of your power problems.

Did that for the reason you noted. Even went so far as to use dd to do the flashing. No change.

And to make things even more interesting, I have downloaded and flashed 2 other image files (raspian-buster-armhf and ubuntu server arm64) and both have flashed and ran with no problems.
I have downloaded the arm64 raspian buster image for the third time in case of a download error, with no change to what I am seeing.

Please provide the exact filename you flashed. We will test that image.


I reflashed both my full os microsd card and the ssd with this image and the card booted fine, the ssd using another microsd card for the flash tool hung as usual. Did a flash of the full raspian 64 bit version on the ssd and it came up just fine.

We have replicated this problem and it’s due to the older GRUB’s handling of compressed files. This is fixed and new images will be available on our distro servers in 24 hours.

It works fine for me?

Thank you for your time and help

You’re probably using the new image. GRUB’s handling of btrfs compression seems to have some corner cases. We disabled compression on the boot directory to accommodate this corner case.

Looks like you updated the armhf version, the arm64 Bullseye, (not Buster) version of Raspian Lite still hangs with the “root account Locked” message when trying to boot from usb ssd using the flash tool.

Please improve your setup description.

  1. Which flashtool?
  2. How are you burning the bootloader to the MicroSD card
  3. How are you burning the image to the USB SSD.
  4. Full bootlogs please. A few photos on your phone and link them here.

Flashtool is the latest from github using the script on the site to download and install to the microsd card.

Raspian Lite arm64 Image burned to ssd using Raspberry Pi Imager,

As for the boot logs, everything thru the grub screen is the same as when using the Buster/armhf version of Raspian lite. Attached is the full screen where everything stops.

Please note that the arm64 Bullseye image of Raspian lite is the ONLY image that seems to do this. The Full arm64 desktop Bullseye Raspian image boots and loads just fine on the same ssd and same boot microsd card. I tried several other arm64 images form the official Libre computer down load site with no problems.

Just tested this path. Flashed MicroSD card with the libretech-flash-tool and flash the USB drive with the image 2022-09-22-raspbian-bullseye-arm64-lite+aml-s905x-cc.img. It booted and worked fine. You probably didn’t wipe your MicroSD card and it has some left over OS.

If it worked fine for you, why do any of your arm64 images (Ubuntu, Raspian full I(with desktop) and others work just fine when flashed to the same ssd using the same sd card? Oh well, I will “clean” and reflash the sdcard with the flash tool and see what happens this time. BTW, it was a brand new sdcard when I flashed it for the first time. I am going to use GParted to clean everything from both the ssd and sd card and start from scratch.

The image is pre-configured to search for UUID. Since the disk images are the same, the UUID of the partitions are the same. There’s no way for GRUB to distinguish so it becomes a race to which was detected first. If you previously imaged the MicroSD card and didn’t wipe the existing partitions, it could be that the partition UUID matched your previous lite image and decided to boot that.

The other images would boot correctly because the UUID didn’t match.