Renegade gentoo install issues

Trying to do a gentoo install with the libre renegade and having some issues.

I built the kernel, modules, and dtb from the latest libretech-linux sources.

When I boot, my display (HDMI) just flashes on and off repeatedly). I do have a TTL UART cable connected to it and see it trying to boot. I’m using an EFI setup with it. I have tried dumping the UART console to a grub command line and loading my kernel manually, gets the same flashing on/off display result with it saying no signal over and over so I’m pretty sure my bootloader is good.

Any suggestions on things to try next troubleshooting wise? (I have successfully done something similar with a potato)

Can you try on a 1080P or lower resolution monitor? There’s a bug with the RK3328 bootloader with high resolution displays at the moment that we’re fixing.

The monitor is a 1080p one. I’ve tried leaving feeding the kernel a command line video=1920x1080 and a 1024x768 resolution. Same result each time. My install did borrow the raspbian uboot environment. My next step will be to try to setup the sd card from scratch, compiling and installing u-boot myself.

I tried going back to basics and doing the absolute minimum per the how to build an image for any distribution post and started over with a different sd card.

I used the libretech-flash-tool on it, got no errors. kernel is installed on my boot partition, but its as if uboot isnt installed correctly even though I used the flash tool.

It doenst seem to even be trying to find my extlinux.conf file, nor does it even offer me an opportunity to escape to a u-boot shell

PMIC: RK8050 (on=0x40, off=0x00)
DDR4, 800MHz
BW=32 Col=10 Bk=4 BG=2 CS0 Row=16 CS1 Row=16 CS=2 Die BW=16 Size=4096MB
Trying to boot from BOOTROM
Returning to boot ROM…
Trying to boot from MMC1
spl: mmc init failed with error: -95
Trying to boot from SPI
SPI probe failed.
Trying to boot from MMC2
Card did not respond to voltage select! : -110
spl: mmc init failed with error: -95
Trying to boot from MMC1
spl: mmc init failed with error: -95
SPL: failed to boot from all boot devices

ERROR ### Please RESET the board

Update: It seems that a timeout needs to be adjusted in the uboot code or something. I have gotten the SD card to be read, but its intermittent. (Tried several cards). When it does read, I can get it to hand off to the kernel and begin booting but same result as before with a custom kernel - screen flashes, never actually comes up and I get non stop panics from what appears to be the rockchipdrm module outputting to the serial console.