Renegate elite wont boot on several OSs

I’ve tried 2 different OSs now with the official images from this site and neither work Ubuntu desktop and raspbian desktop. I’m now trying ubuntu server but I have zero faith it will work. I’ve also swapped power supplies to one that works with other single board computers and it matches the specs, as well I’ve tried different SD cards.
I cannot get the board to boot at all, there is no display output and I can’t see it in the devices connected to the router, nothing.

From looking through other posts it seems like this board has a lot of issues. HDMI doesn’t work, network has issues, uart doesn’t even work on a large number of resolutions… It’s really making me wonder why this board is available.

Have you tried any of the images provided by Firefly? They are very old compared to Libretech’s, but I haven’t had any problems with them.

HDMI and network both work fine. UART resolutions? Do you mean clock frequencies? Please be more specific.

So, I have tried Debian 11/12, I get the following

Begin: Running /scripts/local-block … done.

Raspbian and I am get the following

Begin: Running /scripts/local-block … mdadm: No arrays found in config file or automatically

Both drop out into initramfs

Attached are screen shot. I hooked up my UART cable.

Curiously, I am getting the same exact log on my board right now (previously, it was working perfectly well). Tried different power supplies, different SD cards, can’t figure out what is the problem.

What OS were you running?

I ran the following from the Libre.Computer server

Debian11 and 12

Again these are from download page from Libre.Computer. I did tried Armbian but the board never booted up.