ROC-RK3328-CC-V1.3-B Refusing to Boot

Today I received my ROC-RK3328-CC and have not been able to get it to boot. I have tried a good SanDisk 32gb A1 SD card, 4gb USB 2.0 thumb drive, 64gb USB 3.0 thumb drive, and multiple images (Ubuntu server, desktop, and Raspbian). I am powering the board with a 5v 2amp Samung wall charger and I have tried another 5v 2amp charger that I run my FPGA on. I have tried to boot with and without HDMI plugged in.

When plugging in the power USB cable, the red and green light immediately come on and that is it. Neither of them flicker or dim.

Am I missing something? Do I have to hold the “u-boot” button on the topside of the SD port at any point? The only thing I really have left to do is buy another SD card but this one seems fine. I can read/write to it so it is not locked in read only. Only odd issue is that when trying to verify with win32imager I get a “verification failed at sector 2048.” I have tried with the USB thumb drive as well with the same issue. I followed the youtube video that has me turn off the automount in diskpart but it seems to still be auto mounting.

Any help would be appreciated I would like to have this up and running, thanks.

If you have a FPGA, do you have an UART cable? It’s the quickest way to tell. The u-boot HDMI code for ROC-RK3328-CC will be done around New Year. Pin 34 GND, Pin 36 UART RX, 38 UART TX with 1,500,000 baud rate with no flow control.

1 Like

I don’t have a UART cable but I do have a Digilent PmodUSBUART. I’ve dabbled in serial, I will give this a whirl.

That should work. What OS are you running? Windows should show it in the Device Manager as a COM device. Use putty and set it to serial mode with the correct baud rate and flow control disabled. Then connect the TX and RX pins to 38 and 36 which are 1 pin from the end closest to USB towards the edge of the board. Ground is the pin after that. If you see nothing on putty, try flipping TX and RX pins. When you turn on power with the MicroSD card plugged in, it should start displaying messages. Just copy that here.

1 Like

Hunh… Well I got the PMOD wired correctly but it actually booted this time? Also have video. Armbian in PuTTY terminal is prompting me to create a root password now. I tried a few other things. I didn’t realize I had to restart windows after disabling automount so I did that and then wrote armbian to the SD card and it verified. Thinking that was my issue?

I will try this again with ubuntu server which is what I mostly want.

It’s 2am… I’ve been at this for hours on/off, my brain is hurting.

I’ll try this again with the other images and mark this reply solved if the automount was my issue.


1 Like

We have seen situations where malware would mount the disk and crap all over the place causing the just written image to not work. There’s just so much that can go wrong when flashing on uncontrolled client devices. We just ask for Win32DiskImager verification just to make sure this doesn’t happen and nothing has tampered with the image.

1 Like

This is my serial output trying to run ubuntu-22.10-preinstalled-server-arm64+roc-rk3328-cc.img
Can failing to write corrupt the .img? I could also try a fresh image download.

U-Boot TPL 2022.10+ (Dec 13 2022 - 00:53:03)
DDR4, 800MHz
BW=32 Col=10 Bk=4 BG=2 CS0 Row=16 CS1 Row=16 CS=2 Die BW=16 Size=4096MB
Trying to boot from BOOTROM
Returning to boot ROM…

U-Boot SPL 2022.10+ (Dec 13 2022 - 00:53:03 -0500)
Trying to boot from MMC1
mmc_load_image_raw_sector: mmc block read error
Trying to boot from MMC1
mmc_load_image_raw_sector: mmc block read error
Trying to boot from MMC2
Card did not respond to voltage select! : -110
spl: mmc init failed with error: -95
SPL: failed to boot from all boot devices

ERROR ### Please RESET the board

What is the brand and model of MicroSD card?

I purchased this at Walmart.


Reflashed Armbian_22.11.1_Renegade_jammy_current_5.15.80_minimal.img and it is working again… I will try from a different computer tomorrow with win32di at work and see what happens. I guess if docker works fine on armbian I can just use this. Looking to host Home Assistant/SAMBA Share/Octoprint/VPN with it. I’ll update tomorrow after retrying from another computer, don’t wanna mark it as solved. I also have to use win11 at work so who knows what headaches that will bring me.

We have never tested that MicroSD card model before. We have a dozen SanDisk cards of various models from Amazon and they all work. We ordered one for testing.

1 Like

Update form work: different sd reader/computer, windows 11, still win32d, and SD card. No dice again for Ubuntu server or desktop but armbian still writes successfully and boots. I will probably have to wait until after the holidays to get my hands on a sandisk ultra/samsung sd card. I have another SD card but it’s Walmart’s Onn. brand and my FPGA eats them so I don’t use them for long term storage - just 3D printer files and in my dashcam. If the images flash with another SD, I’ll mark solved with the solution being RTFM haha.

It is good to bring this to our attention as we will add the device to our test matrix and make sure that users know that some MicroSD cards have quirks.

1 Like

So the SD card in my dash camera is around a year old but I looked and it’s the exact same SanDisk imagemate 32gb card. I wrote Ubuntu server to (it which took a really long time) and it wouldn’t verify, same “error at sector 2048” message. I popped it in the board for grins and giggles and it booted straight into your image of Linux server 22.1. Since I have the card, let me know if there’s any tests I can run for you with it.

I guess it was just that other new SD card after all. Could you mark the post solved for my instance just so the banner is there for others.

You’d think in 2022 MicroSD cards would just work XD.

1 Like

Used terminal shut down command to turn off the board, unplugged it, went to the grocery store and another store, come back to no boot. It starts to boot and displays the Ubuntu screen with the loading circle then the display cuts out and the green light either goes out or stays on with no output to serial other than “exiting boot sequence”. I am going to get one of the SanDisk named cards and see if that fixes it.

After “exiting boot sequence”, the UART is disabled by Linux since it moves into GPIO mode. You should get something on your monitor.

1 Like

Ended up being a power supply issue. The one thing I liked about Armbian is that after boot I could still use the UART interface to send commands.

1 Like

Power issues exhibit themselves in a variety of ways. Also power supplies vary tremendously in quality and noise suppression.

1 Like

For what it’s worth, I’m using the USB output from an original MS Surface laptop power adapter. Haven’t had problems extracting or downloading docker images since.