Sim7600 Issuing AT commands, and connecting to mobile network

Hello, we purchased a sim7600 dongle some time ago.

After playing around with the device, I quickly noticed an “issue”. While I’m able to issue AT commands, and receive data back, and enable mobile networking, and browse the internet, I can’t do these things together.

What seems to be the root of the issue, is that Modem/NetworkManager is locking the device when we enable “mobile network”.

This has been an issue for many months, I’ve tried a plethora of suggestions, none of which worked so far:

  • adding a udev rule to exclude Network/ModemManager from locking ttyUSB*.
    All of these have the same issue, if I add the udev rule, ModemManager can’t find the device.

  • Setting up PPP

  • Using ModemManager to issue AT commands instead of writing to ttyUSB* directly

(These were the top 3 that seemed the most promising. There were many others, which I’ve not listed)

I tried contacting Waveshare’s tech-support, they weren’t much of help either.

(Sidenote: an interesting bug(?) occurs sometimes when I issue certain AT commands that change the device in someway (AT+CFUN, AT+CLANMODE, etc…). When I issue those commands, I can enable mobile networking, and read/write to ttyUSB*, temporarily. This changes back after a reboot of the machine)

So far, it seems that our only option is to use an external network adapter, separate from the sim7600 – which is not especially ideal for our customers/machine’s use case.

I would much rather have the option to use the device for both networking and AT commands.

We’re using an Ubuntu 22.04 machine.

Any help, is most welcome. Thank you

Other than recommend that you manually configure networking instead of using a GUI frontend like NM, the manufacturer really needs to provide support for their device.

I wanted to link this article in my “Setting up PPP” section, but couldn’t because I’m a new user.

I tried doing the steps in the article, but whenever I ran sudo pon [file] it failed with the error:

/usr/sbin/pppd: In file /etc/ppp/peers/provider: unrecognized option ‘/dev/ttyUSB3’

I literally copy pasted OPs PPP config file, from the article. Even trying to run pon on the default provider file failed with the same error.
I tried looking online why this error happens but I couldn’t find any leads.
If you have a clue, that’d help me.

What do you mean by:

the manufacturer really needs to provide support for their device

Is this a “known issue”? I couldn’t really find anyone else with this problem
(Using networking and AT commands together, not the locking ttyUSB* ports)

Does ttyUSB3 exist in /dev?

The HAT manufacturer should provide generic Linux setup instructions.

(I am terribly sorry about the late reply)

It does. But issuing the commands is not the problem. As I stated:

“[…] I’m able to issue AT commands, and receive data back”

Surprisingly, the setup for Linux is mostly plug-and-play – which was also true in our case (Assuming you use the proper SIM card).
The manufacturer doesn’t, however, provide instruction for how to issue AT commands and use the device for networking at the same time.
I literally couldn’t not find anything (useful) about this

Usually network setup is done by one manager. If you have multiple sources issuing commands, they overlap. A network manager would acquire exclusive access to the device. If you want to setup something custom, you would have to modify the network manager or handle network setup yourself. It is very unusual for a device to take command streams from two sources since they can clobber each other in the middle of a transaction.

What I get from your reply, is that what I want achieve is likely impossible.

(And this is something I kind already expected, but didn’t want to face)

Would you kindly link me to a “custom setup” of NetworkManager with sim7600?
I tried following Waveshare’s RNDIS setup, I also tried setting up PPP, neither of which worked.
Is there some other resource which I’ve missed?

Ask the manufacturer.

Right, that hasn’t worked very well in the past.
I guess will use an external network adapter, separate from the sim7600.

Thank you very much for the help.