[SOLVED] Bootstrap Debian into the eMMC but GRUB not found

Hi @librecomputer

I followed your advice and tried to bootstrap directly Debian into the eMMC module, but at the end of the process GRUB is still not found, clearly I am missing some key steps but do not which ones.

CHROOT: create and update grub

echo "GRUB_ENABLE_CRYPTODISK=y" >> /etc/default/grub
grub-install /dev/mmcblk0





Reflash bootloader

cd libre[tab]
./lfth.sh bl-flash roc-rk3328-cc mmcblk0 verify


Reboot (removing the SD Card)

Did not work :frowning:

Unfortunately after the reboot it does’t boot.
If I connect the board through HDMI → VGA I can display the buffer, on this other monitor HDMI → HDMI I can’t but the green light is not blinking.

I don’t know where I am mistaken, perhaps this can help anyone to spot it out. I can provide some logs just tell me which I should grab from the eMMC, thanks! :pray:

GRUB needs to be installed in the extra-removables path.

1 Like

Thank you very much :pray:

I apology for my ignorance, what are these extra-removables path?

Thanks! :pray:

Please use Google if you are not clear.

1 Like

It worked, thanks… :+1:

1 Like

This is the much better, cleaner, faster way.

1 Like