[SOLVED] Network race condition with Dropbear

Hi @librecomputer

I am trying to decrypt my board through SSH at boot time, however it looks like the NIC is not properly recognized and therefore Dropbear doesn’t allow you to connect and decrypt during the boot:

When root is unlocked, just right after the NIC is properly recognized.

I found a lot of bug reports about it and apparently it should be already fixed:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=968519

However I have a very similar issue.

Do you know how to fix this? Thanks

You are asking the wrong people.

I am asking because I am using the Linux image you provide from your personal repository and from what I can see you preloaded in the kernel some further modules like the lima driver; and I was wondering if you have made something regarding the NIC, because if it was handled by systemd it would likely name as enx34342ru234023423425923422; while arbitrarily the kernel is assigning the name end0 at the early boot stage:

rk_gmac_dwmac ff540000.ethernet end0: renamed from eth0

I can’t open a Debian Bug Report if I am using a custom kernel image, Thanks! :pray:

Perhaps I got it, I need to pass the IP manually as option into GRUB.

adding this grub solved the issue:

IP=10.0.10.3::::255.255.255.0::end0